Uploaded image for project: 'Flume'
  1. Flume
  2. FLUME-2049

Compile ElasticSearchSink with elasticsearch 0.90

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • 1.4.0, 1.3.1
    • 1.4.0
    • Sinks+Sources
    • None
    • Flume now compiles with elasticsearch 0.90.1. Running Flume with any other major version of elasticsearch will likely require that Flume is compiled with that version.

    Description

      The ElasticSearchSink currently compiles against es 0.19. Using 0.20 requires a recompile. I haven't tried 0.90 yet.

      0.90 has been out for 2-ish weeks so we should change to compiling with it prior to 1.4 release.

      I'm hoping to get priority for doing this in the next two weeks or so - however I have no issue with somebody else doing it.

      Attachments

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            ejsarge Edward Sargisson
            ejsarge Edward Sargisson
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment