Uploaded image for project: 'Flume'
  1. Flume
  2. FLUME-2043

JMS Source removed on failure to create configuration

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.4.0
    • Component/s: Configuration
    • Labels:
      None

      Description

      JMS Source used in agent configuration gets removed on running the agent.

      13/05/11 04:13:17 WARN conf.FlumeConfiguration: Removed jms-source due to Could not create configuration!
      

      The configuration used is:

      agent.sources = jms-source
      agent.channels = memoryChannel
      agent.channels.memoryChannel.type = memory
      agent.sources.jms-source.type = jms
      agent.sources.jms-source.channels = memoryChannel
      agent.sources.jms-source.initialContextFactory = org.apache.activemq.jndi.ActiveMQInitialContextFactory
      agent.sources.jms-source.providerURL = tcp://localhost:61616
      agent.sources.jms-source.destinationName = test
      agent.sources.jms-source.destinationType = queue
      
      1. FLUME-2043.patch
        0.7 kB
        Deepesh Khandelwal

        Issue Links

          Activity

          hudson Hudson added a comment -

          Integrated in flume-trunk #410 (See https://builds.apache.org/job/flume-trunk/410/)
          FLUME-2043. JMS Source removed on failure to create configuration (Revision 51da4db4daded80c3c2ce1a7d69ea8482c769199)

          Result = UNSTABLE
          hshreedharan : http://git-wip-us.apache.org/repos/asf/flume/repo?p=flume.git&a=commit&h=51da4db4daded80c3c2ce1a7d69ea8482c769199
          Files :

          • flume-ng-configuration/src/main/java/org/apache/flume/conf/source/SourceConfiguration.java
          deepesh Deepesh Khandelwal added a comment -

          Thanks Hari for the review and commit.

          hshreedharan Hari Shreedharan added a comment -

          Patch committed, rev: 51da4db, Thanks Deepesh!

          hshreedharan Hari Shreedharan added a comment -

          +1. Patch seems to fix the issue. Running full build and committing.

          hshreedharan Hari Shreedharan added a comment -

          Looks like this is an issue caused by the fact the we usually name our classes ABCSourceConfigurationConstants - which is not the case in JMSSource, where this class actually exists.

          I will run the tests, try running the JMS source and then commit.

          deepesh Deepesh Khandelwal added a comment -

          Patch attached.


            People

            • Assignee:
              deepesh Deepesh Khandelwal
              Reporter:
              deepesh Deepesh Khandelwal
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development