Flume
  1. Flume
  2. FLUME-1986

doTestInflightCorrupts should not commit transactions

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: v1.4.0
    • Component/s: None
    • Labels:
      None

      Description

      This test should not commit the transactions. If it does the inflights would be empty and this does not test corruption of inflights.

      1. FLUME-1986.patch
        3 kB
        Hari Shreedharan
      2. FLUME-1986-1.patch
        5 kB
        Hari Shreedharan

        Issue Links

          Activity

          Flume QA added a comment -

          Here are the results of testing the latest attachment
          https://issues.apache.org/jira/secure/attachment/12578127/FLUME-1986.patch against trunk.

          Overall: -1 due to 3 errors

          ERROR: mvn test exited 1
          ERROR: Failed: org.apache.flume.channel.file.TestFileChannelRestart
          ERROR: Failed: org.apache.flume.channel.file.TestFileChannelRestart

          Console output: https://builds.apache.org/job/PreCommit-FLUME-Build/25/console

          This message is automatically generated.

          Hari Shreedharan added a comment -

          Updated patch.

          Flume QA added a comment -

          Here are the results of testing the latest attachment
          https://issues.apache.org/jira/secure/attachment/12578489/FLUME-1986-1.patch against trunk.

          Overall: -1 due to an error

          ERROR: failed to build with patch (exit code 1)

          Console output: https://builds.apache.org/job/PreCommit-FLUME-Build/26/console

          This message is automatically generated.

          Hari Shreedharan added a comment -

          This failure is unrelated - something that happened due to sphinx failure

          Juhani Connolly added a comment -

          Confirmed and committed, thanks Hari

          Hudson added a comment -

          Integrated in flume-trunk #392 (See https://builds.apache.org/job/flume-trunk/392/)
          FLUME-1986: doTestInflightCorrupts should not commit transactions (Revision 4aaf4a3f86d8ede60dc85a69e8131d2bd8581fca)

          Result = UNSTABLE
          juhani_connolly : http://git-wip-us.apache.org/repos/asf/flume/repo?p=flume.git&a=commit&h=4aaf4a3f86d8ede60dc85a69e8131d2bd8581fca
          Files :

          • flume-ng-channels/flume-file-channel/src/test/java/org/apache/flume/channel/file/TestFileChannelRestart.java
          • flume-ng-channels/flume-file-channel/src/test/java/org/apache/flume/channel/file/TestUtils.java

            People

            • Assignee:
              Hari Shreedharan
              Reporter:
              Hari Shreedharan
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development