Flume
  1. Flume
  2. FLUME-1943

ExecSource tests failing on Jenkins

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: v1.4.0
    • Component/s: None
    • Labels:
      None

      Description

      1. 1943.patch.1
        4 kB
        Roshan Naik

        Activity

        Hudson added a comment -

        Integrated in flume-trunk #376 (See https://builds.apache.org/job/flume-trunk/376/)
        FLUME-1943: ExecSource tests failing on Jenkins (Revision 84fbbdecf95db1a88245f57eae0c4086ecca96ed)

        Result = ABORTED
        brock : http://git-wip-us.apache.org/repos/asf/flume/repo?p=flume.git&a=commit&h=84fbbdecf95db1a88245f57eae0c4086ecca96ed
        Files :

        • flume-ng-core/src/test/java/org/apache/flume/source/TestExecSource.java
        Brock Noland added a comment -

        Thanks Roshan! I Committed to this trunk and 1.4!

        Brock Noland added a comment -

        I think we should try the attached patch.

        Roshan Naik added a comment -

        not getting the context here... do we have a resolution ?

        Brock Noland added a comment -

        I don't think so. The nature of execing processes is kind of error prone. Which was is one of the reasons I was hesitant on this patch. Requiring the user to write a script raises the bar enough to remove some of the user errors. In the end we'll probably just have to create a good doc for the common problems.

        Hari Shreedharan added a comment -

        That is what I was thinking too. Any way we could fix this for good?

        Brock Noland added a comment -

        Thanks for working on this guys. Given our troubles here, I guarantee we'll have a bunch of people on the support list asking "why doesn't this command" work

        Hari Shreedharan added a comment -

        FYI, the bash version:

        Bash version: GNU bash, version 4.2.24(1)-release (x86_64-pc-linux-gnu)
        Copyright (C) 2011 Free Software Foundation, Inc.
        License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
        
        This is free software; you are free to change and redistribute it.
        There is NO WARRANTY, to the extent permitted by law.
        
        Roshan Naik added a comment -

        thats a good suggestion. attached is the patch which adds diagnostics and also uses bash instead. this is for trial only. Preferrably the final patch would drop the diagnostics.

        Brock Noland added a comment -

        Have we tried just changing /bin/sh to /bin/bash?

        Roshan Naik added a comment -

        Hari & I spent some time to see if we could make some changes to the Jenkins job to print diagnostic on shell etc. But it didn't lead to any useful insights. We are currently considering to commit a temporary patch into a for obtaining more detailed diagnostics with regards to the output of the shell commands. This requires changes to the unit tests. It appears that some sort of commit is necessary to make this happen. So Hari suggested we could try committing this patch to a temporary branch.

        Roshan Naik added a comment -

        unable to reproduce locally.. tried both on Linux and Mac. Suspecting something specific to the Jenkins system. Wondering if there is anything about the Jenkins system that is preventing execution of /bin/sh properly.

        Hari, Is it possible to get an output for the following command on the Jenkins system ?
        /bin/sh --version

        Roshan Naik added a comment -

        Taking a look.

        Hari Shreedharan added a comment -

        Roshan Naik - Do you know what's happening?


          People

          • Assignee:
            Roshan Naik
            Reporter:
            Hari Shreedharan
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development