Flume
  1. Flume
  2. FLUME-1831

Flume User Guide specifies default value for bufferMaxLineLength for SpoolDirectorySource when there's no default

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: v1.4.0
    • Fix Version/s: None
    • Component/s: Docs
    • Labels:
      None

      Description

      bufferMaxLineLength doesn't have a default in SpoolDirectorySource:

      Integer bufferMaxLineLength = context.getInteger(BUFFER_MAX_LINE_LENGTH);

      This seems to be by design... it seems that this is a deprecated prop. But the user guide should be upgraded to say that it's deprecated, and to remove the default value.

      1. FLUME-1831.patch
        1.0 kB
        Alexander Alten-Lorenz

        Issue Links

          Activity

          Mike Percy added a comment -

          Thanks, this issue was taken care of as part of FLUME-1800


            People

            • Assignee:
              Alexander Alten-Lorenz
              Reporter:
              Will McQueen
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development