Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: v1.3.0
    • Fix Version/s: None
    • Component/s: Build
    • Labels:
      None
    • Environment:

      jdk1.6 windows7

      Description

      [ERROR] Failed to execute goal org.apache.rat:apache-rat-plugin:0.7:check (test.
      rat) on project flume-ng-core: Too many unapproved licenses: 1 -> [Help 1]
      org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal o
      rg.apache.rat:apache-rat-plugin:0.7:check (test.rat) on project flume-ng-core: T
      oo many unapproved licenses: 1
      at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor
      .java:213)
      at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor
      .java:153)
      at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor
      .java:145)
      at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProje
      ct(LifecycleModuleBuilder.java:84)
      at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProje
      ct(LifecycleModuleBuilder.java:59)
      at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBu
      ild(LifecycleStarter.java:183)
      at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(Lifecycl
      eStarter.java:161)
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:319)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
      at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)
      at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)
      at org.apache.maven.cli.MavenCli.main(MavenCli.java:141)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
      java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
      sorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Laun
      cher.java:290)
      at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.jav
      a:230)
      at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(La
      uncher.java:409)
      at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:
      352)
      Caused by: org.apache.rat.mp.RatCheckException: Too many unapproved licenses: 1
      at org.apache.rat.mp.RatCheckMojo.check(RatCheckMojo.java:167)
      at org.apache.rat.mp.RatCheckMojo.execute(RatCheckMojo.java:159)
      at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(Default
      BuildPluginManager.java:101)
      at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor
      .java:209)
      ... 19 more
      [ERROR]
      [ERROR] Re-run Maven using the -X switch to enable full debug logging.
      [ERROR]
      [ERROR] For more information about the errors and possible solutions, please rea
      d the following articles:
      [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoFailureExc
      eption
      [ERROR]
      [ERROR] After correcting the problems, you can resume the build with the command

      [ERROR] mvn <goals> -rf :flume-ng-core

        Issue Links

          Activity

          YongmingHe created issue -
          Jarek Jarcec Cecho added a comment -

          Hi sir,
          I believe that this is not a bug. RAT is checking all files in flume directory for proper license headers. It appears that you have an extra file without proper license header. It's path will be stored in rat report in target/rat.txt. I would advise removing this file.

          I'll close this ticket for now, but please feel free to reopen if needed.

          Jarcec

          Jarek Jarcec Cecho made changes -
          Field Original Value New Value
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Duplicate [ 3 ]
          Jarek Jarcec Cecho made changes -
          Link This issue duplicates FLUME-1202 [ FLUME-1202 ]
          YongmingHe added a comment -

          Hi Jarcec,
          First,I excute the command mvn clean,the file target/rat.txt has been removed.then I excute the command mvn package -DskipTests.

          the problem still be there,how can I package it correctly?

          thanks

          Yongming He

          Jarek Jarcec Cecho added a comment -

          Well, I would say that you still have file that wasn't there initially and that do not contain proper license header. It seems that you're failing on module flume-ng-core, so I would check rat report in flume-ng-core/target/rat.txt (if it exists).

          Anyway, if you do not want to troubleshoot this, you might run the build with parameter "-Drat.numUnapprovedLicenses=100".

          Jarcec

          YongmingHe added a comment -

          I think I find the reason of this problem,I checked rat report in flume-ng-core/target/rat.txt,find that the problem may be occur becase in flume-ng-core/src/test/resources has a file named events.txt.

          After I removed this file, and set MAVEN_OPTS= -Xms512m -Xmx1024m, then run command "mvn package -DskipTests -Drat.numUnapprovedLicenses=100" the new problem occur.

          [ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:2.
          3.2:compile (default-compile) on project flume-irc-sink: Fatal error compiling:
          Error while executing the compiler. InvocationTargetException: PermGen space ->
          [Help 1]
          org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal o
          rg.apache.maven.plugins:maven-compiler-plugin:2.3.2:compile (default-compile) on
          project flume-irc-sink: Fatal error compiling
          at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor
          .java:217)
          at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor
          .java:153)
          at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor
          .java:145)
          at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProje
          ct(LifecycleModuleBuilder.java:84)
          at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProje
          ct(LifecycleModuleBuilder.java:59)
          at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBu
          ild(LifecycleStarter.java:183)
          at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(Lifecycl
          eStarter.java:161)
          at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:319)
          at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
          at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)
          at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)
          at org.apache.maven.cli.MavenCli.main(MavenCli.java:141)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
          java:39)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
          sorImpl.java:25)
          at java.lang.reflect.Method.invoke(Method.java:597)
          at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Laun
          cher.java:290)
          at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.jav
          a:230)
          at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(La
          uncher.java:409)
          at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:
          352)
          Caused by: org.apache.maven.plugin.MojoExecutionException: Fatal error compiling

          at org.apache.maven.plugin.AbstractCompilerMojo.execute(AbstractCompiler
          Mojo.java:610)
          at org.apache.maven.plugin.CompilerMojo.execute(CompilerMojo.java:128)
          at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(Default
          BuildPluginManager.java:101)
          at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor
          .java:209)
          ... 19 more
          Caused by: org.codehaus.plexus.compiler.CompilerException: Error while executing
          the compiler.
          at org.codehaus.plexus.compiler.javac.JavacCompiler.compileInProcess(Jav
          acCompiler.java:568)
          at org.codehaus.plexus.compiler.javac.JavacCompiler.compile(JavacCompile
          r.java:161)
          at org.apache.maven.plugin.AbstractCompilerMojo.execute(AbstractCompiler
          Mojo.java:605)
          ... 22 more
          Caused by: java.lang.reflect.InvocationTargetException
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
          java:39)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
          sorImpl.java:25)
          at java.lang.reflect.Method.invoke(Method.java:597)
          at org.codehaus.plexus.compiler.javac.JavacCompiler.compileInProcess(Jav
          acCompiler.java:554)
          ... 24 more
          Caused by: java.lang.OutOfMemoryError: PermGen space
          at java.lang.ClassLoader.defineClass1(Native Method)
          at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
          at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:12
          4)
          at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
          at java.net.URLClassLoader.access$000(URLClassLoader.java:56)
          at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
          at java.security.AccessController.doPrivileged(Native Method)
          at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
          at org.codehaus.plexus.compiler.javac.IsolatedClassLoader.loadClass(Isol
          atedClassLoader.java:56)
          at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
          at com.sun.tools.javac.util.ListBuffer.clear(ListBuffer.java:55)
          at com.sun.tools.javac.util.ListBuffer.<init>(ListBuffer.java:51)
          at com.sun.tools.javac.main.RecognizedOptions.getOptions(RecognizedOptio
          ns.java:227)
          at com.sun.tools.javac.main.RecognizedOptions.getJavaCompilerOptions(Rec
          ognizedOptions.java:215)
          at com.sun.tools.javac.main.Main.<init>(Main.java:56)
          at com.sun.tools.javac.Main.compile(Main.java:85)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
          java:39)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
          sorImpl.java:25)
          at java.lang.reflect.Method.invoke(Method.java:597)
          at org.codehaus.plexus.compiler.javac.JavacCompiler.compileInProcess(Jav
          acCompiler.java:554)
          at org.codehaus.plexus.compiler.javac.JavacCompiler.compile(JavacCompile
          r.java:161)
          at org.apache.maven.plugin.AbstractCompilerMojo.execute(AbstractCompiler
          Mojo.java:605)
          at org.apache.maven.plugin.CompilerMojo.execute(CompilerMojo.java:128)
          at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(Default
          BuildPluginManager.java:101)
          at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor
          .java:209)
          at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor
          .java:153)
          at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor
          .java:145)
          at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProje
          ct(LifecycleModuleBuilder.java:84)
          at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProje
          ct(LifecycleModuleBuilder.java:59)
          at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBu
          ild(LifecycleStarter.java:183)
          at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(Lifecycl
          eStarter.java:161)
          [ERROR]
          [ERROR] Re-run Maven using the -X switch to enable full debug logging.
          [ERROR]
          [ERROR] For more information about the errors and possible solutions, please rea
          d the following articles:
          [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionE
          xception
          [ERROR]
          [ERROR] After correcting the problems, you can resume the build with the command

          [ERROR] mvn <goals> -rf :flume-irc-sink

          YongmingHe added a comment -

          thanks,build success! set MAVEN_OPTS= -Xms512m -Xmx1024m -XX:PermSize=256m -XX:MaxPermSize=512m

          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Resolved Resolved
          19m 24s 1 Jarek Jarcec Cecho 16/Jul/12 09:12

            People

            • Assignee:
              Unassigned
              Reporter:
              YongmingHe
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development