Uploaded image for project: 'Flink'
  1. Flink
  2. FLINK-6815

Javadocs don't work anymore in Flink 1.4-SNAPSHOT

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.4.0
    • Fix Version/s: 1.3.1, 1.4.0
    • Component/s: Build System
    • Labels:
      None

      Description

      https://ci.apache.org/projects/flink/flink-docs-master/api/java/org/apache/flink/streaming/api/scala/KeyedStream.html results in a 404 error.

      The problem (https://ci.apache.org/builders/flink-docs-master/builds/731/steps/Java%20&%20Scala%20docs/logs/stdio) is the following:

      [ERROR] Failed to execute goal net.alchim31.maven:scala-maven-plugin:3.2.2:compile (doc) on project flink-annotations: wrap: org.apache.maven.artifact.resolver.ArtifactNotFoundException: Could not find artifact com.typesafe.genjavadoc:genjavadoc-plugin_2.10.6:jar:0.8 in central (https://repo.maven.apache.org/maven2)
      

      I think the problem is that we upgraded the scala version to 2.10.6, but the plugin doesn't have version 0.8 for that scala version.

        Activity

        rmetzger Robert Metzger added a comment -

        I'll update the plugin version to 0.10


          People

          • Assignee:
            rmetzger Robert Metzger
            Reporter:
            rmetzger Robert Metzger
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development