Uploaded image for project: 'Flink'
  1. Flink
  2. FLINK-6797

building docs fails with bundler 1.15

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.3.1, 1.4.0
    • Component/s: Documentation
    • Labels:
      None

      Description

      The script for building the docs installs the latest version of the bundler ruby gem (if it can't find the bundle command, which is always the case on the build-bots, for example). Since the release of bundler 1.15 this fails because it is now pickier about dependency checking, and we somehow ended up with an invalid dependency rule in Gemfile.lock.

        Attachments

          Activity

            People

            • Assignee:
              alpinegizmo David Anderson
              Reporter:
              alpinegizmo David Anderson

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment