Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.2.0, 1.3.0, 1.4.0
    • Fix Version/s: 1.4.0, 1.3.2
    • Component/s: Webfrontend
    • Labels:
      None

      Description

      Steps to reproduce:

      • setup configuration property: jobmanager.web.tmpdir = /mnt/flink/web
      • this directory should not exist
      • Run flink job manager.
      • in logs:
        2017-05-11 12:07:58,397 ERROR org.apache.flink.runtime.webmonitor.WebMonitorUtils           - WebServer could not be created [main]
        java.io.IOException: Jar upload directory /mnt/flink/web/flink-web-3f2733c3-6f4c-4311-b617-1e93d9535421 cannot be created or is not writable.
        

      Expected:

      • create parent directories if they do not exit. i.e. use "uploadDir.mkdirs()" instead of "uploadDir.mkdir()"

      Note:

      • BlobServer create parent directories (See BlobUtils storageDir.mkdirs())

        Issue Links

          Activity

          dernasherbrezon Andrey added a comment -

          Temp directory do not auto-created as well.

          java.io.IOException: Temporary file directory /mnt/flink/tmp does not exist.
          	at org.apache.flink.runtime.taskmanager.TaskManager$$anonfun$checkTempDirs$1.apply(TaskManager.scala:2454)
          
          StephanEwen Stephan Ewen added a comment -

          Good finds!

          Do you want to provide a pull request for these?

          dernasherbrezon Andrey added a comment -

          Hi!

          Sure, I would love to provide pull request. However due to the legal issues, I can't

          githubbot ASF GitHub Bot added a comment -

          GitHub user zentol opened a pull request:

          https://github.com/apache/flink/pull/3894

          FLINK-6541 Improve tmp dir setup in TM/WebMonitor

          This PR contains 2 changes related to temporary directories.

          1. The `WebRuntimeMonitor` now uses `mkdirs` instead of `mkdir`
          2. The `TaskManagerServices` now create the temporary directory if it doesn't already exist.

          You can merge this pull request into a Git repository by running:

          $ git pull https://github.com/zentol/flink 6541_tmp_mkdirs

          Alternatively you can review and apply these changes as the patch at:

          https://github.com/apache/flink/pull/3894.patch

          To close this pull request, make a commit to your master/trunk branch
          with (at least) the following in the commit message:

          This closes #3894


          commit b5f7fa7fea5b2d24a8c9014414fb2f8ca16d66d2
          Author: zentol <chesnay@apache.org>
          Date: 2017-05-13T16:09:30Z

          FLINK-6541 Improve tmp dir setup in TM/WebMonitor


          githubbot ASF GitHub Bot added a comment -

          Github user zentol commented on the issue:

          https://github.com/apache/flink/pull/3894

          merging.

          githubbot ASF GitHub Bot added a comment -

          Github user asfgit closed the pull request at:

          https://github.com/apache/flink/pull/3894

          Zentol Chesnay Schepler added a comment -

          1.3: ff2bb718cd9e87dfe7ab5601e9ff9f7293eb3cfe
          1.4: 721640778aa88b6491baf837278a873493f283f0


            People

            • Assignee:
              Zentol Chesnay Schepler
              Reporter:
              dernasherbrezon Andrey
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development