Uploaded image for project: 'Flink'
  1. Flink
  2. FLINK-5828

BlobServer create cache dir has concurrency safety problem

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.3.0, 1.2.1
    • Component/s: Core
    • Labels:
      None

      Description

      Caused by: java.lang.RuntimeException: org.apache.flink.client.program.ProgramInvocationException: The program execution failed: Could not upload the jar files to the job manager.
      at FlinkJob_20170217_161058_000004.bind(FlinkJob_20170217_161058_000004.java:45)
      at com.aliyun.kepler.rc.query.schedule.FlinkQueryJob.call(FlinkQueryJob.java:53)
      at com.aliyun.kepler.rc.query.schedule.FlinkQueryJob.call(FlinkQueryJob.java:13)
      at java.util.concurrent.FutureTask.run(FutureTask.java:262)
      at java.util.concurrent.AbstractExecutorService$2.run(AbstractExecutorService.java:120)
      ... 3 common frames omitted
      Caused by: org.apache.flink.client.program.ProgramInvocationException: The program execution failed: Could not upload the jar files to the job manager.
      at com.aliyun.kepler.rc.flink.client.Client.runBlocking(Client.java:178)
      at org.apache.flink.api.java.ClientEnvironment.execute(ClientEnvironment.java:169)
      at org.apache.flink.api.java.ClientEnvironment.execute(ClientEnvironment.java:225)
      at FlinkJob_20170217_161058_000004.bind(FlinkJob_20170217_161058_000004.java:42)
      ... 7 common frames omitted
      Caused by: org.apache.flink.runtime.client.JobSubmissionException: Could not upload the jar files to the job manager.
      at org.apache.flink.runtime.client.JobClientActor$2.call(JobClientActor.java:359)
      at akka.dispatch.Futures$$anonfun$future$1.apply(Future.scala:94)
      at scala.concurrent.impl.Future$PromiseCompletingRunnable.liftedTree1$1(Future.scala:24)
      at scala.concurrent.impl.Future$PromiseCompletingRunnable.run(Future.scala:24)
      at akka.dispatch.TaskInvocation.run(AbstractDispatcher.scala:41)
      ... 3 common frames omitted
      Caused by: java.io.IOException: Could not retrieve the JobManager's blob port.
      at org.apache.flink.runtime.blob.BlobClient.uploadJarFiles(BlobClient.java:706)
      at org.apache.flink.runtime.jobgraph.JobGraph.uploadUserJars(JobGraph.java:556)
      at org.apache.flink.runtime.client.JobClientActor$2.call(JobClientActor.java:357)
      ... 7 common frames omitted
      Caused by: java.io.IOException: PUT operation failed: Server side error: Could not create cache directory '/home/kepler/kepler3012/data/work/blobs/blobStore-c3566cb2-b3d6-40ae-bdcf-594a81c8881b/cache'.
      at org.apache.flink.runtime.blob.BlobClient.putInputStream(BlobClient.java:476)
      at org.apache.flink.runtime.blob.BlobClient.put(BlobClient.java:338)
      at org.apache.flink.runtime.blob.BlobClient.uploadJarFiles(BlobClient.java:730)
      at org.apache.flink.runtime.blob.BlobClient.uploadJarFiles(BlobClient.java:701)
      ... 9 common frames omitted

        Issue Links

          Activity

          StephanEwen Stephan Ewen added a comment -

          Fixed in

          • 1.2.1 via 8a5d56d448db752c9779a32d5a6f907b0232b489
          • 1.3.0 via 20420fc6ee153c7171265dda7bf7d593c17fb375
          githubbot ASF GitHub Bot added a comment -

          Github user asfgit closed the pull request at:

          https://github.com/apache/flink/pull/3342

          githubbot ASF GitHub Bot added a comment -

          Github user StephanEwen commented on the issue:

          https://github.com/apache/flink/pull/3342

          Merging this...

          githubbot ASF GitHub Bot added a comment -

          Github user StephanEwen commented on the issue:

          https://github.com/apache/flink/pull/3342

          Good fix, thank you!

          +1 to merge this

          githubbot ASF GitHub Bot added a comment -

          GitHub user bwzheng2010 opened a pull request:

          https://github.com/apache/flink/pull/3342

          TO FLINK-5828

          flip the logic to resolve currency safety problem

          [flink-runtime]
          https://issues.apache.org/jira/browse/FLINK-5828

          fix currency safety problem for this issue

          You can merge this pull request into a Git repository by running:

          $ git pull https://github.com/bwzheng2010/flink FLINK-5828

          Alternatively you can review and apply these changes as the patch at:

          https://github.com/apache/flink/pull/3342.patch

          To close this pull request, make a commit to your master/trunk branch
          with (at least) the following in the commit message:

          This closes #3342


          commit e58a89b6a53a32dea2667ea800509948859623fb
          Author: 士远 <bowen.zheng@alipay.com>
          Date: 2017-02-17T09:42:22Z

          TO FLINK-5828

          flip the logic to resolve currency safety problem



            People

            • Assignee:
              Unassigned
              Reporter:
              bowen.zheng ZhengBowen
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development