Uploaded image for project: 'Flink'
  1. Flink
  2. FLINK-5732

Java quick start mvn command line is incorrect

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 1.2.0
    • Fix Version/s: 1.2.1
    • Component/s: Documentation
    • Labels:
      None

      Description

      On this page:

      https://ci.apache.org/projects/flink/flink-docs-release-1.2/quickstart/java_api_quickstart.html

      Within the "Create Project" section it reads:

      $ mvn archetype:generate \
      -DarchetypeGroupId=org.apache.flink \
      -DarchetypeArtifactId=flink-quickstart-java \
      -DarchetypeVersion=1.2

      However this is incorrect, it should read:

      $ mvn archetype:generate \
      -DarchetypeGroupId=org.apache.flink \
      -DarchetypeArtifactId=flink-quickstart-java \
      -DarchetypeVersion=1.2.0

      (1.2 .0 not 1.2)

        Activity

        Hide
        uce Ufuk Celebi added a comment -

        Thanks for spotting this. Fixed in 87697f4 (release-1.2).

        Show
        uce Ufuk Celebi added a comment - Thanks for spotting this. Fixed in 87697f4 (release-1.2).

          People

          • Assignee:
            uce Ufuk Celebi
            Reporter:
            colinbreame Colin Breame
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development