Uploaded image for project: 'Flink'
  1. Flink
  2. FLINK-5575

in old releases, warn users and guide them to the latest stable docs

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.0.4, 1.2.0, 1.3.0, 1.1.5
    • Component/s: Documentation
    • Labels:
      None

      Description

      Old versions of Flink (especially version 0.8) are being frequently studied, downloaded, and used by new users (because google leads them there). I propose to guide folks to the latest stable release by adding a link on every documentation page in the old docs that links to the home page of the latest stable docs.

      The redirect lives at flink.apache.org/q/stable-docs.html, and will need to be modified with each major release (e.g. when 1.2 is released).

      This problem affects all releases before 1.1, but the stats show that 0.8, 0.9, 0.10, and 1.0 are the most important to deal with.

        Attachments

          Activity

            People

            • Assignee:
              alpinegizmo David Anderson
              Reporter:
              alpinegizmo David Anderson
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: