Uploaded image for project: 'Flink'
  1. Flink
  2. FLINK-5275

InputChanelDeploymentDescriptors throws misleading Exception if producer failed/cancelled

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.2.0, 1.1.4
    • Component/s: Network
    • Labels:
      None

      Description

      Reported by Robert Metzger. While creating the input channel deployment descriptors for a job that does not allow lazy deployment (all streaming jobs), Robert got an ExecutionGraphException with the message Trying to eagerly schedule a task whose inputs are not ready in the InputChannelDeploymentDescriptor.

      This was not reported as the root cause and is most likely due to a failed producer. For such cases, it makes sense to include the execution state of the producing task so that users see that this is related to the producer.

        Activity

        uce Ufuk Celebi added a comment -

        4410c04 (master), 4526005 (release-1.1)


          People

          • Assignee:
            uce Ufuk Celebi
            Reporter:
            uce Ufuk Celebi
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development