Uploaded image for project: 'Flink'
  1. Flink
  2. FLINK-5274

LocalInputChannel throws NPE if partition reader is released

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.2.0, 1.1.4
    • Component/s: Network
    • Labels:
      None

      Description

      Reported by Robert Metzger:

      java.lang.NullPointerException
             at org.apache.flink.runtime.io.network.partition.consumer.LocalInputChannel.getNextBuffer(LocalInputChannel.java:185)
             at org.apache.flink.runtime.io.network.partition.consumer.SingleInputGate.getNextBufferOrEvent(SingleInputGate.java:444)
             at org.apache.flink.streaming.runtime.io.BarrierBuffer.getNextNonBlocked(BarrierBuffer.java:152)
             at org.apache.flink.streaming.runtime.io.StreamInputProcessor.processInput(StreamInputProcessor.java:195)
             at org.apache.flink.streaming.runtime.tasks.OneInputStreamTask.run(OneInputStreamTask.java:67)
             at org.apache.flink.streaming.runtime.tasks.StreamTask.invoke(StreamTask.java:267)
             at org.apache.flink.runtime.taskmanager.Task.run(Task.java:638)
             at java.lang.Thread.run(Thread.java:745)
      

      This is most likely caused by the result partition being released after the notifcations have happened.

        Activity

        uce Ufuk Celebi added a comment -

        555a687 (master), 1b472d2 (release-1.1)


          People

          • Assignee:
            uce Ufuk Celebi
            Reporter:
            uce Ufuk Celebi
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development