Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 1.1.3
    • Fix Version/s: None
    • Component/s: CEP
    • Labels:
      None

      Description

      Currently the CEP library stores all the keys it has seen so far, so that when the time comes, it can iterate over all the stored NFAs and update them accordingly.

      This implies that the state is never cleaned up and it can lead to memory issues.

      To improve this, we could register timers for each new element and for the specific key, so that 1) only the relevant NFAs are fetched, and 2) the timers will be gc'ed upon firing.

        Activity

        aljoscha Aljoscha Krettek added a comment -

        FLINK-5420 is also a bit of a duplicate of this issue.


          People

          • Assignee:
            kkl0u Kostas Kloudas
            Reporter:
            kkl0u Kostas Kloudas
          • Votes:
            2 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development