Uploaded image for project: 'Flink'
  1. Flink
  2. FLINK-3813

YARNSessionFIFOITCase.testDetachedMode failed on Travis

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 1.1.0, 1.2.0
    • Fix Version/s: 1.2.0, 1.1.4
    • Component/s: None
    • Labels:

      Description

      The YARNSessionFIFOITCase.testDetachedMode failed on Travis.

      https://s3.amazonaws.com/archive.travis-ci.org/jobs/125560038/log.txt

        Issue Links

          Activity

          mxm Maximilian Michels added a comment -

          master: e4807621b8f41fc4f9fa69f423f1fbf7bba05218
          release-1.1: 42334de84a85aa98432bde6dd817f5060e7ce036

          githubbot ASF GitHub Bot added a comment -

          Github user asfgit closed the pull request at:

          https://github.com/apache/flink/pull/2749

          githubbot ASF GitHub Bot added a comment -

          GitHub user mxm opened a pull request:

          https://github.com/apache/flink/pull/2749

          FLINK-3813[yarn] wait for CLI to complete before checking output

          You can merge this pull request into a Git repository by running:

          $ git pull https://github.com/mxm/flink FLINK-3813

          Alternatively you can review and apply these changes as the patch at:

          https://github.com/apache/flink/pull/2749.patch

          To close this pull request, make a commit to your master/trunk branch
          with (at least) the following in the commit message:

          This closes #2749


          commit e747d94215792ac68fde871226b49d6322a76781
          Author: Maximilian Michels <mxm@apache.org>
          Date: 2016-11-03T14:11:10Z

          FLINK-3813[yarn] wait for CLI to complete before checking output


          mxm Maximilian Michels added a comment -

          This is caused by the main thread not waiting on the thread which runs the CLI (Runner).


            People

            • Assignee:
              mxm Maximilian Michels
              Reporter:
              till.rohrmann Till Rohrmann
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development