Uploaded image for project: 'Flink'
  1. Flink
  2. FLINK-3618

Rename abstract UDF classes in Scatter-Gather implementation

    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Closed
    • Minor
    • Resolution: Implemented
    • 1.0.1, 1.1.0
    • 1.1.0
    • None

    Description

      We now offer three Vertex-centric computing abstractions:

      • Pregel
      • Gather-Sum-Apply
      • Scatter-Gather

      Each of these abstractions provides abstract classes that need to be implemented by the user:

      • Pregel: ComputeFunction
      • GSA: GatherFunction, SumFunction, ApplyFunction
      • Scatter-Gather: MessagingFunction, VertexUpdateFunction

      In Pregel and GSA, the names of those functions follow the name of the abstraction or the name suggested in the corresponding papers. For consistency of the API, I propose to rename MessageFunction to ScatterFunction and VertexUpdateFunction to GatherFunction.

      Also for consistency, I would like to change the parameter order in Graph.runScatterGatherIteration(VertexUpdateFunction f1, MessagingFunction f2 to Graph.runScatterGatherIteration(ScatterFunction f1, GatherFunction f2 (like in Graph.runGatherSumApplyFunction(...))

      Attachments

        Issue Links

          Activity

            People

              greghogan Greg Hogan
              mju Martin Junghanns
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: