XMLWordPrintableJSON

    Details

      Description

      Background

      EFO requires the AWS SDK v2.x dependency. Version 1.x cannot be removed from the project as other modules require it (DynamoDB streams and KPL), therefore we will use AWS SDK 1.x and 2.x side by side.

      Scope

      This change will introduce the new dependency and Kinesis V2 proxy:

      • Update pom file to include the new dependency
        • This should be shaded and relocated into the connector jar (similar to V1)
      • Add a KinesisProxyV2¬†skeleton interface (methods and implementation will come in follow up tasks)
      • Add utility methods to create an AWS SDK v2.x Kinesis Client from connector properties, including:
        • Region
        • Credential Provider¬†
        • HTTP Client config
        • Other properties

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                danny.cranmer Danny Cranmer
                Reporter:
                danny.cranmer Danny Cranmer
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: