Uploaded image for project: 'Flink'
  1. Flink
  2. FLINK-16635

Incompatible okio dependency in flink-metrics-influxdb module

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    Description

      With FLINK-12147 we bumped influxdb-java from version 2.14 to 2.16. At the same time we fix the okio dependency to version 1.14.0. Since influxdb-java transitive dependency converter-moshi:jar:2.6.1 requires moshi:jar:1.8.0 which requires okio:jar:1.16.0, the influxdb metric reporter fails as described here. We should fix this incompatibility by removing the dependency management entry for okio.

      Attachments

        Issue Links

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            trohrmann Till Rohrmann
            trohrmann Till Rohrmann
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0h
                0h
                Logged:
                Time Spent - 20m
                20m

                Issue deployment