Apache Flex
  1. Apache Flex
  2. FLEX-16400

[Gumbo-priority] Defaults.css in haloclassic.swc shows errros when we try to compile it to a swf

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Not A Problem
    • Affects Version/s: Adobe Flex SDK Previous
    • Fix Version/s: None
    • Component/s: Themes
    • Labels:
      None
    • Environment:
      Affected OS(s): Windows
      Affected OS(s): Windows XP
      Language Found: English

      Description

      Steps to reproduce:

      1. Goto sdks/4.0.0/framewroks/themes/Haloclassic
      2. Extract defaults.css file from haloclassic.swc
      3. Open command prompt and try compiling defaults.css

      C:\depot\flex\ide_common\com.adobe.flexide.flex\devsdks\4.0.0\bin>mxmlc -include-libraries=..\frameworks\themes\HaloClassic\haloclassic.swc ..\frameworks\themes\HaloClassic\defaults.css

      Actual Results:
      Loading configuration file C:\depot\flex\ide_common\com.adobe.flexide.flex\devsd
      ks\4.0.0\frameworks\flex-config.xml

      C:\depot\flex\ide_common\com.adobe.flexide.flex\devsdks\4.0.0\frameworks\themes\
      HaloClassic\defaults.css(245): Error: definition for symbol 'mx.skins.applicatio
      n.ApplicationBackground' not found

      defaultBackgroundImage: Embed(source="Assets.swf",symbol="mx.skins.appli
      cation.ApplicationBackground");

      C:\depot\flex\ide_common\com.adobe.flexide.flex\devsdks\4.0.0\frameworks\themes\
      HaloClassic\defaults.css(245): Error: Unable to transcode C:/depot/flex/ide_comm
      on/com.adobe.flexide.flex/devsdks/4.0.0/frameworks/libs/framework.swc$Assets.swf.

      Expceted results
      No errors during compilation. defaults.swf should be generated without any errors

      Workaround (if any): None

        Activity

        Adobe JIRA added a comment -

        Adobe Bug URL: http://bugs.adobe.com/jira/browse/SDK-17902
        Original Reporter: deeptika
        Original Resolution: External
        Discoverability: Medium
        Number of votes: 0
        Regression: Yes
        Reproducibility: Every Time
        Resolved by: gruehle
        Severity: Non Functioning
        reporter: deeptika

        Adobe JIRA added a comment -

        created: 2008-11-04 03:04:57.000
        resolved: 2008-11-04 09:38:55.308
        updated: 2011-04-15 15:24:14.000

        Adobe JIRA added a comment -

        On 2008-11-04 03:07:33.945 deeptika commented:
        This is an issue with latest SDK. This was working fine in SDK 3803.
        Fast tracking this bug as Gumbo priority because this bug affects Themes workflow
        On 2008-11-04 08:55:17.480 rvollmar commented:
        In build 4.0.0.4009, I carried out the steps above.

        On the Mac I encountered some errors such as this:

        Error: exception during transcoding: /Users/rv/builds/trunk/4.0.0.4009/frameworks/themes/HaloClassic/Assets.swf (Permission denied)

        defaultBackgroundImage: Embed(source="Assets.swf",symbol="mx.skins.application.ApplicationBackground");

        /Users/rv/builds/trunk/4.0.0.4009/frameworks/themes/HaloClassic/defaults.css(245): Error: Unable to transcode /Users/rv/builds/trunk/4.0.0.4009/frameworks/themes/HaloClassic/Assets.swf.

        After giving myself read access to the files extracted from the SWC, I was able to compile. However, I have the same experience with build 3803, which is reported as working ok.

        On Windows, I had no errors.

        What build was this bug reported on?
        On 2008-11-04 09:38:55.537 gruehle commented:
        To build haloclassic as a style module, you need to do the following:
        1. cd to frameworks/projects/haloclassic
        2. copy Assets.swf from the assets directory to the current directory
        3. run 'mxmlc --source-path=src defaults.css'

        You will get a warning about the BusyCursor symbol, but the file will compile fine.
        On 2008-11-04 09:58:38.529 rvollmar commented:
        Closing. The file haloclassic.swc contains an Assets.swf file from 1/3/2008; perhaps that needs to be removed. I'll ask around.
        On 2008-11-04 20:12:09.707 deeptika commented:
        It worked fine in gumbo FB build 213575 which has 4.0.0_3803 SDK but not with 214272 which has 4.0.0_3971 SDK.
        This is fixed in changelist 214416 by adding Assets.swf also to the Haloclassic theme directory.


          People

          • Assignee:
            Adobe JIRA
            Reporter:
            Adobe JIRA
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development