Details

    • Type: New Feature
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: User Admin
    • Labels:

      Description

      I've written a new implementation of the UserAdmin specification that I want to donate to the Felix project.

      This implementation is backed by an extensive test suite (200+ tests) to keep an eye on regression in the various parts of the implementation. Of course, it is compliant to the UserAdmin specification.

      In addition, it offers the possibility to use another backend repository for the storage of roles. By default, it uses an file-based repository, making it a fully self-contained service.

      I am willing to maintain this implementation in the future if accepted in the main source tree of Felix.

      1. useradmin-mongodb-1.0.0-src.tgz
        10 kB
        J.W. Janssen
      2. useradmin-filestore-1.0.0-src.tgz
        13 kB
        J.W. Janssen
      3. useradmin-1.0.2-src.tgz
        27 kB
        J.W. Janssen
      4. sha1.txt
        0.5 kB
        J.W. Janssen

        Activity

        jajans J.W. Janssen added a comment -

        Committed original contribution in rev.1391437; updated versions to snapshots in rev.1391458.

        marrs Marcel Offermans added a comment -

        You're probably right, Richard, so just to be on the safe side I started a new vote on this updated version of the contribution and will continue the IP clearance when that vote closes.

        rickhall Richard S. Hall added a comment -

        Hmm. Not sure about this, but we voted on the previous archive and SHA1, so it is not clear to me whether we need to revote or not.

        jajans J.W. Janssen added a comment -

        I believe a small bug crept into the filestore implementation. Due to this, uploaded all contributions again + new SHA hashes.

        jajans J.W. Janssen added a comment -

        Uploaded latest revision of the implementation.

        • split off the (default) file-based store from the main bundle to its own bundle;
        • added a mongo-db store implementation;
        • some bug fixes found during some field tests.
        jajans J.W. Janssen added a comment -

        Uploaded new version of the UA implementation.

        Updated sources to include proper ASF headers (for those files that missed them). Also cleaned the bundle manifest a bit.

        jajans J.W. Janssen added a comment -

        Added SHA-1 hash of useradmin-1.0.0-src.tgz.

        rickhall Richard S. Hall added a comment -

        Sounds nice. Could you include the MD5 hash or something similar for the archive you uploaded. Thanks!

        jajans J.W. Janssen added a comment - - edited

        Added the initial sources of the UserAdmin implementation.


          People

          • Assignee:
            jajans J.W. Janssen
            Reporter:
            jajans J.W. Janssen
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development