Uploaded image for project: 'Falcon'
  1. Falcon
  2. FALCON-1976

Remove hadoop-2 profile

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: trunk, 0.10
    • Component/s: None
    • Labels:
      None

      Description

      I have been debugging the hbase backend issue and with maven 3.3.9 everything works fine, but it looks like

      • jenkins pre-commit is using 3.2.x
      • Some of the RE folks I talked to say there are still using 3.1.1

      So, after a few experiments, I see that dependency management within a profile works very well only in 3.3.9 (test classpath gets messed up in various ways in 3.2.x version of maven for some reason. changing surefire plugin version does not help either). Patching this in child poms is either hacky or not elegant.

      So, removing hadoop-2 profile as we no longer support hadoop-1 and this resolves many of the 3.2.5 issues

      Also saw that falcon-unit is having its own version of hadoop version (2.7.1) instead of using the parent pom version. This might be the cause of some intermittent issues people were reporting. I will create a JIRA to move falcon-unit to addons just like hivedr, hdfs-snapshot-mirroring etc that require higher component versions

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                venkatnrangan Venkat Ranganathan
                Reporter:
                venkatnrangan Venkat Ranganathan
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: