Commons Email
  1. Commons Email
  2. EMAIL-32

[email] tests fail on Unix c/o port settings

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: Nightly Builds
    • Fix Version/s: None
    • Labels:
      None
    • Environment:

      Operating System: Mac OS X 10.0
      Platform: Macintosh

      Description

      this bug was patched and has sneaked in again. Port testings during tests weren't being set to the
      values set in EmailConfiguration. Submitting a patch that fixes this.

        Activity

        Mark Lowe created issue -
        Mark Lowe added a comment -

        Created an attachment (id=13554)
        [email] smtp port setting *nix during tests

        Corey Scott added a comment -

        Created an attachment (id=13569)
        Changes the port number to 2500 from 25 (as this is reserved on unix)

        Corey Scott added a comment -
            • COM-1693 has been marked as a duplicate of this bug. ***
        Corey Scott added a comment -

        Created an attachment (id=13571)
        previous patch was invalid, resubmitting

        David Eric Pugh added a comment -

        Okay, I've applied this patch. When CVS is working I'll commit it.

        David Eric Pugh added a comment -

        Committed. Can someone test this and verify the fix?

        Joe Germuska added a comment -

        I have run the tests on Mac OS X and verified that they work without being 'root'.

        Henri Yandell made changes -
        Field Original Value New Value
        issue.field.bugzillaimportkey 32410 12341898
        Henri Yandell made changes -
        Affects Version/s 1.0 Alpha [ 12311665 ]
        Component/s Email [ 12311114 ]
        Key COM-1746 EMAIL-32
        Assignee Jakarta Commons Developers Mailing List [ commons-dev@jakarta.apache.org ]
        Project Commons [ 12310458 ] Commons Email [ 12310474 ]
        Henri Yandell made changes -
        Affects Version/s 1.0 Alpha [ 12311833 ]
        Siegfried Goeschl made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Resolved Resolved Closed Closed
        2156d 3h 4m 1 Siegfried Goeschl 23/Oct/10 23:17

          People

          • Assignee:
            Unassigned
            Reporter:
            Mark Lowe
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development