Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 1.2
    • Fix Version/s: 1.3
    • Labels:

      Description

      I'm not too experienced with filing bug reports and I don't know how to make a patch file, so I'll just do it like this. I also don't know whether this is fixed already in an unreleased version... But I just hope I can help.

      On line 1240 of Email.java in version 1.2 of Commons Email, the message of the exception is extended with this.getSmtpPort. This is incorrect; this should be something like:

      (this.isSSL()?this.getSslSmtpPort():this.getSmtpPort())

      Else it results in questions like http://stackoverflow.com/questions/13951322/javamail-email-commons-empty-message-gives-strange-error

        Issue Links

          Activity

          Bart Laarhoven created issue -
          Bart Laarhoven made changes -
          Field Original Value New Value
          Description I'm not too experienced with filing bug reports and I don't know how to make a patch file, so I'll just do it like this. I also don't know whether this is fixed already in an unreleased version... But I just hope I can help.

          On line 1240 of Email.java in version 1.2 of Commons Email, the message of the exception is extended with this.getSmtpPort. This is incorrect; this should be something like:

          (this.isSSL()?this.getSslSmtpPort():this.getSmtpPort())

          Else there are questions like http://stackoverflow.com/questions/13951322/javamail-email-commons-empty-message-gives-strange-error
          ;-)
          I'm not too experienced with filing bug reports and I don't know how to make a patch file, so I'll just do it like this. I also don't know whether this is fixed already in an unreleased version... But I just hope I can help.

          On line 1240 of Email.java in version 1.2 of Commons Email, the message of the exception is extended with this.getSmtpPort. This is incorrect; this should be something like:

          (this.isSSL()?this.getSslSmtpPort():this.getSmtpPort())

          Else it results in questions like http://stackoverflow.com/questions/13951322/javamail-email-commons-empty-message-gives-strange-error
          ;-)
          Bart Laarhoven made changes -
          Link This issue relates to EMAIL-91 [ EMAIL-91 ]
          Bart Laarhoven added a comment -

          It seems related to this issue, but I can't see whether/how issue 91 will solve this one.

          Thomas Neidhart added a comment -

          This bug report is indeed a duplicate of EMAIL-91.

          I added a unit test in r1429382 to verify the now correct behavior.

          Thanks for the report anyway!

          Thomas Neidhart made changes -
          Link This issue duplicates EMAIL-91 [ EMAIL-91 ]
          Thomas Neidhart made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Fix Version/s 1.3 [ 12315052 ]
          Resolution Fixed [ 1 ]
          Thomas Neidhart made changes -
          Resolution Fixed [ 1 ]
          Status Resolved [ 5 ] Reopened [ 4 ]
          Thomas Neidhart made changes -
          Status Reopened [ 4 ] Resolved [ 5 ]
          Resolution Duplicate [ 3 ]
          Thomas Neidhart made changes -
          Link This issue relates to EMAIL-91 [ EMAIL-91 ]
          Thomas Neidhart made changes -
          Status Resolved [ 5 ] Closed [ 6 ]

            People

            • Assignee:
              Unassigned
              Reporter:
              Bart Laarhoven
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development