Uploaded image for project: 'Apache Drill'
  1. Apache Drill
  2. DRILL-5509

Upgrade Drill protobuf support from 2.5.0 to latest 3.3

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Duplicate
    • Affects Version/s: 1.10.0
    • Fix Version/s: 1.16.0
    • Component/s: None
    • Labels:
      None

      Description

      Drill uses Google Protobufs for RPC. Drill's Maven compile requires version 2.5.0 from Feb. 2013. The latest version is 3.3. Over time, it may become increasingly hard to find and build a four-year-old version.

      Upgrade Drill to use the latest Protobuf version. This will require updating the Maven protobuf plugin, and may require other upgrades as well.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                agozhiy Anton Gozhiy
                Reporter:
                paul-rogers Paul Rogers
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: