Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.1.0, 1.2.0
    • Fix Version/s: 1.2.0
    • Component/s: Storage - Other
    • Labels:
      None

      Description

      Running a simple select * from an avro file fails.

      > select count(*) from `divolte.avro`;
      Error: SYSTEM ERROR: UnsupportedOperationException: Unimplemented type: UNION
      
      Fragment 0:0
      
      [Error Id: c7c1ed87-cd85-4146-844d-4addc227128b on abhi1:31010] (state=,code=0)
      

      Plan:

      00-00    Screen
      00-01      Project(*=[$0])
      00-02        Scan(groupscan=[EasyGroupScan [selectionRoot=maprfs:/tmp/divolte.avro, numFiles=1, columns=[`*`], files=[maprfs:///tmp/divolte.avro]]])
       

      Log & data file attached.

      1. divolte.avro
        3 kB
        Abhishek Girish
      2. drillbit.log.txt
        12 kB
        Abhishek Girish

        Issue Links

          Activity

          agirish Abhishek Girish added a comment -

          Turns out I confused this with UNION operator. Have updated the title suitably.

          __andrew Andrew added a comment -

          I think the patch linked from DRILL-3458 should resolve this. In my limited tests the patch works, but I don't have a real data set in front of me at the moment to put it through the paces.

          __andrew Andrew added a comment -

          I have confirmed that the attached file works on the current master branch.


            People

            • Assignee:
              Unassigned
              Reporter:
              agirish Abhishek Girish
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development