Uploaded image for project: 'Apache Drill'
  1. Apache Drill
  2. DRILL-3303

Build doesn't support recent version of Java

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      I am unable to build drill. I get the following error:
      Failed to execute goal org.apache.maven.plugins:maven-enforcer-plugin:1.3.1:enforce (validate_java_and_maven_version) on project drill-root: Some Enforcer rules have failed. Look above for specific messages explaining why the rule failed. -> [Help 1]

      It looks like my java version is too recent. Do I need to install an old version or should this be updated in the build configuration?
      [WARNING] Rule 1: org.apache.maven.plugins.enforcer.RequireJavaVersion failed with message:
      Detected JDK Version: 1.8.0-45 is not in the allowed range [1.7,1.8).

      I followed these steps:
      git clone https://github.com/apache/drill.git
      mvn clean install

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                kingofhypocrites Levi Page
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: