Apache Drill
  1. Apache Drill
  2. DRILL-88 HBase storage engine
  3. DRILL-300

Move to "com.codahale.metrics" from "com.yammer.metrics"

    Details

    • Type: Sub-task Sub-task
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.0-milestone-1
    • Fix Version/s: None
    • Labels:
      None

      Description

      Yammer's metrics-core 3.x APIs conflict with 2.x API and hence it is impossible to use a code which uses 2.x API (e.g. HBase).

      The good news is that the new metrics API have a new maven coordinate and new FQCN and hence it is possible for drill to use the new APIs while still work with libraries which use older metrics APIs.

      1. DRILL-300.patch
        32 kB
        Aditya Kishore

        Activity

        Show
        Aditya Kishore added a comment - https://reviews.apache.org/r/15642/
        Hide
        Jacques Nadeau added a comment -

        merged in 3e20003

        Show
        Jacques Nadeau added a comment - merged in 3e20003

          People

          • Assignee:
            Aditya Kishore
            Reporter:
            Aditya Kishore
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development