Uploaded image for project: 'CXF Distributed OSGi'
  1. CXF Distributed OSGi
  2. DOSGI-83

The multibundle distribution fails to start on Equinox

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.1
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      I followed the instructions for running the multibundle distribution using Equinox.

      When the framework comes up, listing the bundles shows this:

      34 ACTIVE cxf-dosgi-ri-discovery-local_1.3.0.SNAPSHOT
      35 INSTALLED cxf-dosgi-ri-dsw-cxf_1.3.0.SNAPSHOT
      36 ACTIVE cxf-dosgi-ri-topology-manager_1.3.0.SNAPSHOT

      Attempting to start bundle 35 leads to:

      osgi> start 35
      org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Package uses conflict: Import-Package: org.apache.cxf; version="2.2.0"
      at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError(AbstractBundle.java:1313)
      at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolutionFailureException(AbstractBundle.java:1297)
      at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:309)
      at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:280)
      at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:272)
      at org.eclipse.osgi.framework.internal.core.FrameworkCommandProvider._start(FrameworkCommandProvider.java:253)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.eclipse.osgi.framework.internal.core.FrameworkCommandInterpreter.execute(FrameworkCommandInterpreter.java:155)
      at org.eclipse.osgi.framework.internal.core.FrameworkConsole.docommand(FrameworkConsole.java:303)
      at org.eclipse.osgi.framework.internal.core.FrameworkConsole.console(FrameworkConsole.java:288)
      at org.eclipse.osgi.framework.internal.core.FrameworkConsole.run(FrameworkConsole.java:224)
      at java.lang.Thread.run(Thread.java:637)

      The behaviour is the same in both trunk and the most recent release.
      The multibundle distribution runs fine on a Felix platform.

        Activity

        sergey_beryozkin Sergey Beryozkin added a comment -

        Please try the updated 1.3-SNAPSHOT and reopen if it is still an issue

        zoe zoe slattery added a comment -

        Hi - it's not an issue for me because I'm not even remotely interested in using it any more, I'm sure that if you can't reproduce it, it must have been fixed. No doubt someone else will raise another JIRA if it hasn't been.
        Zoe

        sergey_beryozkin Sergey Beryozkin added a comment -

        > No doubt someone else will raise another JIRA if it hasn't been

        Yep, thanks


          People

          • Assignee:
            Unassigned
            Reporter:
            zoe zoe slattery
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development