CXF Distributed OSGi
  1. CXF Distributed OSGi
  2. DOSGI-153

Error starting greeter sample in karaf 2.3.0 in aegis setup: ExceptionInInitializerError ... failed to create an XPathFactory for the default object model: http://java.sun.com/jaxp/xpath/dom

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.4.0
    • Fix Version/s: 1.4.0
    • Component/s: DSW
    • Labels:
      None
    • Environment:

      Apache Karaf 2.3.0

    • Estimated Complexity:
      Unknown

      Description

      To reproduce simply start a clean karaf 2.3.0 and run the following
      commands:

      features:addurl mvn:org.apache.cxf.dosgi/cxf-dosgi/1.4-SNAPSHOT/xml/features
      features:install cxf-dosgi-discovery-local
      install -s
      mvn:org.apache.cxf.dosgi.samples/cxf-dosgi-ri-samples-greeter-interface/1.4-SNAPSHOT
      install -s
      mvn:org.apache.cxf.dosgi.samples/cxf-dosgi-ri-samples-greeter-impl/1.4-SNAPSHOT

      The following exception below shows directly on the console.


      Exception in thread "pool-12-thread-1" java.lang.ExceptionInInitializerError
      at
      org.apache.cxf.aegis.type.XMLTypeCreator.<init>(XMLTypeCreator.java:138)
      at
      org.apache.cxf.aegis.AegisContext.createRootTypeCreator(AegisContext.java:122)
      at
      org.apache.cxf.aegis.AegisContext.createTypeCreator(AegisContext.java:111)
      at org.apache.cxf.aegis.AegisContext.initialize(AegisContext.java:153)
      at
      org.apache.cxf.aegis.databinding.AegisDatabinding.initialize(AegisDatabinding.java:232)
      at
      org.apache.cxf.service.factory.AbstractServiceFactoryBean.initializeDataBindings(AbstractServiceFactoryBean.java:86)
      at
      org.apache.cxf.service.factory.ReflectionServiceFactoryBean.buildServiceFromClass(ReflectionServiceFactoryBean.java:474)
      at
      org.apache.cxf.service.factory.ReflectionServiceFactoryBean.initializeServiceModel(ReflectionServiceFactoryBean.java:536)
      at
      org.apache.cxf.service.factory.ReflectionServiceFactoryBean.create(ReflectionServiceFactoryBean.java:248)
      at
      org.apache.cxf.frontend.AbstractWSDLBasedEndpointFactory.createEndpoint(AbstractWSDLBasedEndpointFactory.java:101)
      at
      org.apache.cxf.frontend.ServerFactoryBean.create(ServerFactoryBean.java:159)
      at
      org.apache.cxf.dosgi.dsw.handlers.AbstractPojoConfigurationTypeHandler.createServerFromFactory(AbstractPojoConfigurationTypeHandler.java:208)
      at
      org.apache.cxf.dosgi.dsw.handlers.PojoConfigurationTypeHandler.createServer(PojoConfigurationTypeHandler.java:117)
      at
      org.apache.cxf.dosgi.dsw.service.RemoteServiceAdminCore.exportService(RemoteServiceAdminCore.java:120)
      at
      org.apache.cxf.dosgi.dsw.service.RemoteServiceAdminInstance$1.run(RemoteServiceAdminInstance.java:71)
      at
      org.apache.cxf.dosgi.dsw.service.RemoteServiceAdminInstance$1.run(RemoteServiceAdminInstance.java:64)
      at java.security.AccessController.doPrivileged(Native Method)
      at
      org.apache.cxf.dosgi.dsw.service.RemoteServiceAdminInstance.exportService(RemoteServiceAdminInstance.java:64)
      at
      org.apache.cxf.dosgi.dsw.service.RemoteServiceAdminInstance.exportService(RemoteServiceAdminInstance.java:37)
      at
      org.apache.cxf.dosgi.topologymanager.exporter.TopologyManagerExport.doExportService(TopologyManagerExport.java:250)
      at
      org.apache.cxf.dosgi.topologymanager.exporter.TopologyManagerExport.access$200(TopologyManagerExport.java:51)
      at
      org.apache.cxf.dosgi.topologymanager.exporter.TopologyManagerExport$3.run(TopologyManagerExport.java:214)
      at
      java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      at
      java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:662)
      Caused by: java.lang.RuntimeException: XPathFactory#newInstance() failed
      to create an XPathFactory for the default object model:
      http://java.sun.com/jaxp/xpath/dom with the
      XPathFactoryConfigurationException:
      javax.xml.xpath.XPathFactoryConfigurationException: No XPathFctory
      implementation found for the object model:
      http://java.sun.com/jaxp/xpath/dom
      at javax.xml.xpath.XPathFactory.newInstance(Unknown Source)
      at org.apache.cxf.helpers.XPathUtils.<clinit>(XPathUtils.java:39)
      ... 25 more

        Activity

        Christian Schneider added a comment -

        Dan hinted to this solution:
        This might be among the issues we fixed in the 2.2.0 version of the servicemix specs. Can you replace the lib/endorsed/org.apache.servicemix.specs.jaxp-api-1.4-2.1.0.jar file from Karaf 2.3.0 with the 2.2.0 version and see if that helps?

        The new jaxb api version will be included in Karaf 2.3.1. So to use DOSGI with aegis upgrade karaf to version 2.3.1.


          People

          • Assignee:
            Christian Schneider
            Reporter:
            Christian Schneider
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development