CXF Distributed OSGi
  1. CXF Distributed OSGi
  2. DOSGI-114

RemoteServiceAdmin is not available warnings in DOSGi 1.3

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.3
    • Fix Version/s: 1.4.0
    • Component/s: DSW
    • Labels:
      None
    • Estimated Complexity:
      Unknown

      Description

      Some users have reported that the RemoteServiceAdmin is not available in 1.3, example:
      "SEVERE: No RemoteServiceAdmin available! Unable to export service from
      bundle cxf-dosgi-ri-samples-greeter-rest-impl"

      Needs to be confirmed with the existing demos

        Activity

        Amichai Rothman added a comment -

        I'm not familiar with the full history of this issue, but thought it might be helpful to mention that DOSGI-160 and DOSGI-161, which were recently fixed in 1.5, could also be possible causes for the "No RemoteServiceAdmin available" error (in addition to whatever was fixed in 1.4). In my own experience I haven't seen the error since working with the fixes in 1.5. It would be great to hear if anyone can reproduce this or related issues in a current 1.5 snapshot.

        Ronald Müller added a comment -

        Hi,

        i recently migrated from 1.2 to 1.4 (multi-bundle) downloaded from here: http://repository.apache.org/service/local/repositories/releases/content/org/apache/cxf/dosgi/cxf-dosgi-ri-multibundle-distribution/1.4.0/cxf-dosgi-ri-multibundle-distribution-1.4.0-dir.tar.gz and encounted this bug. But could resolve this by using the latest version (1.5-trunk) from the apache jenkins repositories (https://builds.apache.org/job/CXF-DOSGi/ws/trunk/distribution/multi-bundle/target/cxf-dosgi-ri-multibundle-distribution-1.5-SNAPSHOT-dir/apache-cxf-dosgi-ri-1.5-SNAPSHOT/dosgi_bundles/).
        So my question is: is this bug really fixed in 1.4 (as stated here)?

        regards

        Ronald

        Christian Schneider added a comment -

        Thanks for testing

        TangYong added a comment -

        Hi Christian,

        Just Now, I have confirmed greeter sample using dcxf trunk and felix 4.0.3, the issue has been fixed. Please seeing the following,

        g! lb
        START LEVEL 1
        ID|State |Level|Name
        0|Active | 0|System Bundle (4.0.3)
        1|Active | 1|Apache Felix Bundle Repository (1.6.6)
        2|Active | 1|Apache Felix Gogo Command (0.12.0)
        3|Active | 1|Apache Felix Gogo Runtime (0.10.0)
        4|Active | 1|Apache Felix Gogo Shell (0.10.0)
        5|Resolved | 1|osgi.cmpn (4.2.0.200908310645)
        6|Active | 1|Distributed OSGi Distribution Software Single-Bundle Dis
        tribution (1.4.0.SNAPSHOT)
        7|Active | 1|CXF Distributed OSGi Greeter Demo Interface Bundle (1.4.
        0.SNAPSHOT)
        g! install file:/d:/gf/cxf-dosgi-ri-samples-greeter-client-1.4-SNAPSHOT.jar
        Bundle ID: 8
        g! start 8
        g! 2012/11/29 20:24:55 org.apache.cxf.service.factory.ReflectionServiceFactoryBe
        an buildServiceFromClass
        情報: Creating Service

        {http://greeter.samples.dosgi.cxf.apache.org/}

        GreeterServ
        ice from class org.apache.cxf.dosgi.samples.greeter.GreeterService

            • Opening greeter client dialog ***
            • Invoking greeter ***
              greetMe("foobar") returns:
              Hola foobar
              Bonjour foobar
              Hoi foobar
              Hello foobar
            • Opening greeter client dialog ***

        Thanks your fixing!
        --Tang

        Christian Schneider added a comment -

        No problem I just need the confirmation till start of next week as I am planning to do the 1.4 release mid next week.

        TangYong added a comment -

        Hi Christian,

        I am sorry for letting you wait long time because recently I am too busy. Now, I am building trunk, this evening, I will give you a confirmation.Please wait for a while again.

        Christian Schneider added a comment -

        Any success with the test?

        TangYong added a comment -

        I will try trunk on Next Week, once having result , I will reply you.

        Thanks.
        Tang

        Christian Schneider added a comment -

        Can you retest with trunk. I think I have removed the warning as it is absolutely fine that the RSA is installed after the TopologyManager. When it is installed later the endpoints should be exported.

        Sergey Beryozkin added a comment - - edited

        I think this exception may be unrelated to this warning, example, if you try a greeter or greeter_rest demo then you will see it works even with this warning

        TangYong added a comment -

        >1 dcxf 1.2

        >single distro : OK
        >multi bundles : I am doing (should ok)

        multi bundles : OK

        TangYong added a comment -

        >3 dcxf 1.3.1

        >single distro : I am doing
        single distro : problem still happened, and stacktrace is as following:

        org.apache.cxf.interceptor.Fault: Could not send Message.
        at org.apache.cxf.interceptor.MessageSenderInterceptor$MessageSenderEndingInterceptor.handleMessage(MessageSenderInterceptor.java:64)
        at org.apache.cxf.phase.PhaseInterceptorChain.doIntercept(PhaseInterceptorChain.java:263)
        at org.apache.cxf.endpoint.ClientImpl.doInvoke(ClientImpl.java:533)
        at org.apache.cxf.endpoint.ClientImpl.invoke(ClientImpl.java:463)
        at org.apache.cxf.endpoint.ClientImpl.invoke(ClientImpl.java:366)
        at org.apache.cxf.endpoint.ClientImpl.invoke(ClientImpl.java:319)
        at org.apache.cxf.frontend.ClientProxy.invokeSync(ClientProxy.java:88)
        at org.apache.cxf.frontend.ClientProxy.invoke(ClientProxy.java:80)
        at $Proxy22.greetMe(Unknown Source)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.apache.cxf.dosgi.dsw.handlers.ServiceInvocationHandler$1.run(ServiceInvocationHandler.java:63)
        at java.security.AccessController.doPrivileged(Native Method)
        at org.apache.cxf.dosgi.dsw.handlers.ServiceInvocationHandler.invoke(ServiceInvocationHandler.java:61)
        at $Proxy23.greetMe(Unknown Source)
        at org.apache.cxf.dosgi.samples.greeter.client.Activator.greeterUI(Activator.java:71)
        at org.apache.cxf.dosgi.samples.greeter.client.Activator.access$000(Activator.java:32)
        at org.apache.cxf.dosgi.samples.greeter.client.Activator$2.run(Activator.java:59)
        at java.lang.Thread.run(Thread.java:662)
        Caused by: java.net.SocketTimeoutException: SocketTimeoutException invoking http://localhost:9090/greeter: Read timed out
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
        at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
        at org.apache.cxf.transport.http.HTTPConduit$WrappedOutputStream.mapException(HTTPConduit.java:1431)
        at org.apache.cxf.transport.http.HTTPConduit$WrappedOutputStream.close(HTTPConduit.java:1416)
        at org.apache.cxf.transport.AbstractConduit.close(AbstractConduit.java:56)
        at org.apache.cxf.transport.http.HTTPConduit.close(HTTPConduit.java:649)
        at org.apache.cxf.interceptor.MessageSenderInterceptor$MessageSenderEndingInterceptor.handleMessage(MessageSenderInterceptor.java:62)
        ... 20 more
        Caused by: java.net.SocketTimeoutException: Read timed out
        at java.net.SocketInputStream.socketRead0(Native Method)
        at java.net.SocketInputStream.read(SocketInputStream.java:129)
        at java.io.BufferedInputStream.fill(BufferedInputStream.java:218)
        at java.io.BufferedInputStream.read1(BufferedInputStream.java:258)
        at java.io.BufferedInputStream.read(BufferedInputStream.java:317)
        at sun.net.www.http.HttpClient.parseHTTPHeader(HttpClient.java:690)
        at sun.net.www.http.HttpClient.parseHTTP(HttpClient.java:633)
        at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1195)
        at java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:379)
        at org.apache.cxf.transport.http.HTTPConduit$WrappedOutputStream.handleResponseInternal(HTTPConduit.java:1542)
        at org.apache.cxf.transport.http.HTTPConduit$WrappedOutputStream.handleResponse(HTTPConduit.java:1494)
        at org.apache.cxf.transport.http.HTTPConduit$WrappedOutputStream.close(HTTPConduit.java:1402)
        ... 23 more
        Exception in thread "Thread-3" org.osgi.framework.ServiceException: REMOTE
        at org.apache.cxf.dosgi.dsw.handlers.ServiceInvocationHandler.invoke(ServiceInvocationHandler.java:82)
        at $Proxy23.greetMe(Unknown Source)
        at org.apache.cxf.dosgi.samples.greeter.client.Activator.greeterUI(Activator.java:71)
        at org.apache.cxf.dosgi.samples.greeter.client.Activator.access$000(Activator.java:32)
        at org.apache.cxf.dosgi.samples.greeter.client.Activator$2.run(Activator.java:59)
        at java.lang.Thread.run(Thread.java:662)
        Caused by: java.lang.reflect.InvocationTargetException
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.apache.cxf.dosgi.dsw.handlers.ServiceInvocationHandler$1.run(ServiceInvocationHandler.java:63)
        at java.security.AccessController.doPrivileged(Native Method)
        at org.apache.cxf.dosgi.dsw.handlers.ServiceInvocationHandler.invoke(ServiceInvocationHandler.java:61)
        ... 5 more
        Caused by: org.apache.cxf.interceptor.Fault: Could not send Message.
        at org.apache.cxf.interceptor.MessageSenderInterceptor$MessageSenderEndingInterceptor.handleMessage(MessageSenderInterceptor.java:64)
        at org.apache.cxf.phase.PhaseInterceptorChain.doIntercept(PhaseInterceptorChain.java:263)
        at org.apache.cxf.endpoint.ClientImpl.doInvoke(ClientImpl.java:533)
        at org.apache.cxf.endpoint.ClientImpl.invoke(ClientImpl.java:463)
        at org.apache.cxf.endpoint.ClientImpl.invoke(ClientImpl.java:366)
        at org.apache.cxf.endpoint.ClientImpl.invoke(ClientImpl.java:319)
        at org.apache.cxf.frontend.ClientProxy.invokeSync(ClientProxy.java:88)
        at org.apache.cxf.frontend.ClientProxy.invoke(ClientProxy.java:80)
        at $Proxy22.greetMe(Unknown Source)
        ... 12 more
        Caused by: java.net.SocketTimeoutException: SocketTimeoutException invoking http://localhost:9090/greeter: Read timed out
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
        at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
        at org.apache.cxf.transport.http.HTTPConduit$WrappedOutputStream.mapException(HTTPConduit.java:1431)
        at org.apache.cxf.transport.http.HTTPConduit$WrappedOutputStream.close(HTTPConduit.java:1416)
        at org.apache.cxf.transport.AbstractConduit.close(AbstractConduit.java:56)
        at org.apache.cxf.transport.http.HTTPConduit.close(HTTPConduit.java:649)
        at org.apache.cxf.interceptor.MessageSenderInterceptor$MessageSenderEndingInterceptor.handleMessage(MessageSenderInterceptor.java:62)
        ... 20 more
        Caused by: java.net.SocketTimeoutException: Read timed out
        at java.net.SocketInputStream.socketRead0(Native Method)
        at java.net.SocketInputStream.read(SocketInputStream.java:129)
        at java.io.BufferedInputStream.fill(BufferedInputStream.java:218)
        at java.io.BufferedInputStream.read1(BufferedInputStream.java:258)
        at java.io.BufferedInputStream.read(BufferedInputStream.java:317)
        at sun.net.www.http.HttpClient.parseHTTPHeader(HttpClient.java:690)
        at sun.net.www.http.HttpClient.parseHTTP(HttpClient.java:633)
        at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1195)
        at java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:379)
        at org.apache.cxf.transport.http.HTTPConduit$WrappedOutputStream.handleResponseInternal(HTTPConduit.java:1542)
        at org.apache.cxf.transport.http.HTTPConduit$WrappedOutputStream.handleResponse(HTTPConduit.java:1494)
        at org.apache.cxf.transport.http.HTTPConduit$WrappedOutputStream.close(HTTPConduit.java:1402)
        ... 23 more

        TangYong added a comment - - edited

        Hi David, Sergey,

        Now, I have been doing a new confirmation on current and previous apache dcxf, the result is as following:

        1 dcxf 1.2

        single distro : OK
        multi bundles : I am doing (should ok)

        2 dcxf 1.3

        single distro : problem happened
        multi bundles : problem happened

        3 dcxf 1.3.1

        single distro : I am doing
        multi bundles : problem happened

        Sergey Beryozkin added a comment -

        David, this is coming from TopologyManagerImport. Can you comment please on what TopologyManagerImport does and if we can just remove this warning, given that the end-to-end application still works ? May be we can just 'downgrade' it to a trace-level warning ?

        TangYong added a comment -

        Hi Team,

        I have also met the same problem on the same machine using DCXF 1.3.1 as following,
        ...

        Unable to import service (

        {endpoint.id=http://127.0.0.1:9090/greeter, objectClass=[org.apache.cxf.dosgi.samples.greeter.GreeterService], service.imported=true, service.imported.configs=org.apache.cxf.ws}

        ): no RemoteServiceAdmin service available!
        ...

        And I used multi distro, and I want know whether having fix plan or not?

        --Tang Yong

        Sergey Beryozkin added a comment -

        I've seen the confirmation of the successful publication too.
        I think this issue applies to a single distro only. I propose to replace a 'severe' level statement with a fine-level message which will notify that
        RemoteServiceAdmin is not available yet.

        Rasmus Lock Fuglsang added a comment -

        After some more digging, the RemoteServiceAdmin is actually being published, just not until later, so the log will (wrongly?) contain the above SEVERE entry, even though the TopologyManager correctly exports the services once the RemoteServiceAdmin is registered.

        Rasmus Lock Fuglsang added a comment -

        We are seing the same in our deployment, running cxf-dosgi-ri-singlebundle-distribution 1.3.1


          People

          • Assignee:
            Christian Schneider
            Reporter:
            Sergey Beryozkin
          • Votes:
            2 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development