Uploaded image for project: 'Qpid Dispatch'
  1. Qpid Dispatch
  2. DISPATCH-1525

KeyError when executing master branch qdstat -l (links) against 1.9.0 router on Python 3

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Closed
    • Major
    • Resolution: Fixed
    • None
    • 1.10.0
    • Management Agent, Tools
    • None

    Description

      Run the following test in a Python 3 environment -

      1. Start version 1.9.0 of the router
      2. Run a qdstat -l command against the 1.9.0 router
      3. You will see an error --> KeyError: deliveriesStuck

      You should be able to run a newer qdstat command against the currently released version of the router (1.9.0)

       

      Note: This works when running the router on Python 2.7 but fails when running the router on Python 3.8

       

       

      Attachments

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            kgiusti Ken Giusti
            gmurthy Ganesh Murthy
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment