Directory Studio
  1. Directory Studio
  2. DIRSTUDIO-962

Crash at startup : gtk_widget_get_tooltip_text

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.5.3, 2.0.0
    • Component/s: studio-apacheds
    • Labels:
    • Environment:
      OpenJDK 64-Bit Server VM (23.7-b01 mixed mode linux-amd64 compressed oops) on an Ubuntu machine

      Description

      The app crashes before the progress bar on the splash screen.

      1. hs_err_pid24539.log
        112 kB
        Grégoire Paris

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        474d 20h 40m 1 Emmanuel Lecharny 11/Mar/15 13:47
        Resolved Resolved Reopened Reopened
        8d 16m 1 EMR 19/Mar/15 14:03
        Reopened Reopened Resolved Resolved
        79d 9h 18m 1 Stefan Seelmann 07/Jun/15 00:21
        Stefan Seelmann made changes -
        Status Reopened [ 4 ] Resolved [ 5 ]
        Fix Version/s 2.0.0-M9 [ 12324644 ]
        Resolution Fixed [ 1 ]
        Stefan Seelmann added a comment -

        Upcoming release 2.0.0-M9 based on Eclipse Luna should fix the issue.

        EMR added a comment - - edited

        Please note that I needed to add a parameter to make it work under Fedora 21 KDE-Spin. Nothing suggested earlier worked (keeping Oxygen theme) until this param was prepended "gtk_data_prefix".

        GTK_DATA_PREFIX="" GTK2_RC_FILES=/usr/share/themes/Bluecurve/gtk-2.0/gtkrc ./ApacheDirectoryStudio

        EMR added a comment -

        FWIW here's what seems to work for me:
        In KDE (Fedora 21, YMMV)

        • KDE default theme is set to Oxygen via: system settings -> Application Appearance -> Style
        • running oxygen-settings program from the command line, and disabling Animation -> select 'advanced options' and uncheck 'menu highlight' (I believe you can access this from the GUI via "system settings -> Application Appearance -> Style -> Widget Style -> Oxygen -> Configure")
        • Gtk+ Appearance: system settings -> Application Appearance -> Gtk+ Appearance is set to "Clearlooks"

        The only problem with this is that your GTK apps would look different from your KDE apps. So I set the gtk style back to oxygen and used the GTK2_RC_FILES variable to point to clearlooks before starting the app to no avail; it would still crash.

        Emmanuel Lecharny added a comment -

        There is nothing we can do. This is clearly a KDE or GTK issue, as shown in this (long) thread : https://bugs.kde.org/show_bug.cgi?id=324438

        EMR made changes -
        Resolution Unresolved [ 9 ]
        Status Resolved [ 5 ] Reopened [ 4 ]
        EMR added a comment -

        I logged out of KDE, logged into GNOME, used the gnome-tweak-tool to update my UI settings (overriding the kde settings), and I still cannot get apache directory studio working at all. This is including all the suggestions in this forum.

        Please investigate, or at least provide concise instructions (dependencies, etc.) on how to build this application on Fedora 21.

        ApacheDirectoryStudio-linux-x86-2.0.0.v20130628

        #

        1. A fatal error has been detected by the Java Runtime Environment:
          #
        2. SIGSEGV (0xb) at pc=0x4f4b05d8, pid=19024, tid=3062594368
          #
        3. JRE version: Java(TM) SE Runtime Environment (8.0_40-b25) (build 1.8.0_40-b25)
        4. Java VM: Java HotSpot(TM) Server VM (25.40-b25 mixed mode linux-x86 )
        5. Problematic frame:
        6. C [libgtk-x11-2.0.so.0+0x2b15d8] gtk_widget_get_tooltip_text+0x38
          #
        7. Core dump written. Default location: /run/media/exr003/Ext120/DOWNLOADS/ApacheDirectoryStudio-linux-x86-2.0.0.v20130628/core or core.19024 (max size 100000 kB). To ensure a full core dump, try "ulimit -c unlimited" before starting Java again
          #
        8. An error report file with more information is saved as:
        9. /run/media/exr003/Ext120/DOWNLOADS/ApacheDirectoryStudio-linux-x86-2.0.0.v20130628/hs_err_pid19024.log
          #
        10. If you would like to submit a bug report, please visit:
        11. http://bugreport.java.com/bugreport/crash.jsp
        12. The crash happened outside the Java Virtual Machine in native code.
        13. See problematic frame for where to report the bug.
          #
        Emmanuel Lecharny made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Unresolved [ 9 ]
        Emmanuel Lecharny added a comment -

        I'm closing this issue. This is certainly not a Studio issue, and it's a problem on GTK only, plus there is a workaround.

        I don't see what we can do to improve the situation here...

        David Couture added a comment -

        Stefan, that worked for me.

        Xfce on Debian 8.0 with ADS-linux-x86_64-2.0.0.v20130628.

        /dc.

        Stefan Seelmann added a comment -

        A possible solution from John Harris:

        A solution seems to be to create a "ini" configuration file and tune the software stack to the local environment.

        Of particular importance is the last line. [ -Dorg.eclipse.swt.internal.gtk.cairoGraphics=false ]

        Contents of working 'ApacheDirectoryStudio.ini' for Linux, located in the product directory, as per the install guidelines;

        ## This is the magic line, the rest is site and product specific, as required.
        -Dorg.eclipse.swt.internal.gtk.cairoGraphics=false
        
        

        To start, you can copy and paste this into a "INI" file and tune as required.
        Strip out the comments not required and adjust your settings (Xms / Xmx / XX:MaxPermSize ) as required.

        This is a minimal solution, please refer to the Java manuals and guides for a complete list of options.
        Please be conservative, at least to start.
        Modify a line at a time, an option at a time.
        Should you not need anything else, leave it out.

        Also disable any other workaround that you may have active, including the ones noted for 'DIRSTUDIO-962'.

        This was tested on a Centos 6 (workstation) x86-64 platform with 16GB of memory using a Tyan S7002 Mobo with Dual xeons running a slightly modified KDE.
        However, providing your hardware is stable, hardware shouldn't be an issue.

        The issue at hand appears to be the recent GTK upgrades to Debian, Redhat and related platforms.
        This fix also seems to work on prior legacy Eclipse based platforms before Eclipse Luna.

        I would also assume, but have not tested on all such products, that this would work on legacy Eclipse platforms that utilise legacy (prior to Luna) Eclipse.
        I.E. Aptana Studio, Zend Studio, LibreSource, the IBM eclipse based Tools, etc.

        For other platforms, refer to their guidelines for creating an "INI" file and it's correct location.

        However, as that may be, the only way to find out, is to throw it out there and test it.
        Some feedback, Good, Bad or Indifferent, would also be good, guys.

        This works for me in: Apache directory Studio (Version: 2.0.0.v20130628) for Linux.

        Scott Mead added a comment -

        Okay, I found a work-around for this. There was a setting that I was not aware of that got defaulted by a yum install.

        Fedora 20, KDE, System Settings -> Application Appearance -> GTK+ Appearance
        Change the widget style there and your issue will be solved.

        On a side note, I'm not sure if there is a plan yet, but I would love to get the DirStudio plugins working in Luna...

        Scott Mead added a comment -

        I have replicated this on Fedora 20 using both the bundled OpenJDK and the Oracle JDK. The above work around has no effect.

        I have tried this using the following both with and without the GTK2_RC_FILES workaround.

        OpenJDK -> ApacheDirectoryStudio ( fail )
        OpenJDK -> Eclipse 4.2 ( Juno ) ( fails on perspective load )
        OpenJDK -> Eclipse 4.3 ( Kepler ) ( fails on perspective load )
        OpenJDK -> Eclipse Luna ( plugin installs, but perspective not available )

        Oracle -> ApacheDirectoryStudio ( fail )
        Oracle -> Eclipse 4.2 ( Juno ) ( fails on perspective load )
        Oracle -> Eclipse 4.3 ( Kepler ) ( fails on perspective load )
        Oracle -> Eclipse Luna ( plugin installs, but perspective not available )

        OpenJDK
        $ ./ApacheDirectoryStudio
        #

        1. A fatal error has been detected by the Java Runtime Environment:
          #
        2. SIGSEGV (0xb) at pc=0x00007f2c958ad522, pid=29322, tid=139830229673728
          #
        3. JRE version: OpenJDK Runtime Environment (7.0_60-b30) (build 1.7.0_60-mockbuild_2014_06_19_16_23-b00)
        4. Java VM: OpenJDK 64-Bit Server VM (24.60-b09 mixed mode linux-amd64 compressed oops)
        5. Problematic frame:
        6. C [libgtk-x11-2.0.so.0+0x284522] gtk_widget_get_tooltip_text+0x32
          #
        7. Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
          #
        8. An error report file with more information is saved as:
        9. /tmp/jvm-29322/hs_error.log
          #
        10. If you would like to submit a bug report, please include
        11. instructions on how to reproduce the bug and visit:
        12. http://icedtea.classpath.org/bugzilla
          #

        Oracle
        $ GTK2_RC_FILES=/usr/share/themes/Radiance/gtk-2.0/gtkrc ./ApacheDirectoryStudio
        #

        1. A fatal error has been detected by the Java Runtime Environment:
          #
        2. SIGSEGV (0xb) at pc=0x00007f8e0df48522, pid=29402, tid=140248793679616
          #
        3. JRE version: Java(TM) SE Runtime Environment (7.0_65-b17) (build 1.7.0_65-b17)
        4. Java VM: Java HotSpot(TM) 64-Bit Server VM (24.65-b04 mixed mode linux-amd64 compressed oops)
        5. Problematic frame:
        6. C [libgtk-x11-2.0.so.0+0x284522] gtk_widget_get_tooltip_text+0x32
          #
        7. Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
          #
        8. An error report file with more information is saved as:
        9. /home/scottm/software/apache/ApacheDirectoryStudio-linux-x86_64-2.0.0.v20130628/hs_err_pid29402.log
          #
        10. If you would like to submit a bug report, please visit:
        11. http://bugreport.sun.com/bugreport/crash.jsp
          #
        Nicolas Costes added a comment -

        Stefan, I installed Eclipse from the Mageia repos and then the Studio plugin : it works fine, thanks, although it took time for me to understand how to setup the right view . Thanks !

        Stefan Seelmann added a comment -

        Nicolas, at the moment I can only give you the advice to
        1) Download a full Eclipse installation from http://eclipse.org/downloads/ or Install Eclipse from your Linux distribution repository
        2) Then install the Studio plugins as described in https://directory.apache.org/studio/installation-in-eclipse.html

        Emmanuel Lecharny added a comment -

        I don't really see what we can do. It's more than likely a bug in some Linux lib that causes Eclipse to crash.

        Nicolas Costes added a comment -

        Hello, all ! Same bug here, even when applying the workaround :

        $ GTK2_RC_FILES=/usr/share/themes/Radiance/gtk-2.0/gtkrc ./ApacheDirectoryStudio
        #

        1. A fatal error has been detected by the Java Runtime Environment:
          #
        2. SIGSEGV (0xb) at pc=0x00007feb05f25bc3, pid=3555, tid=140648180881152
          #
        3. JRE version: OpenJDK Runtime Environment (7.0_45-b15) (build 1.7.0_45-iurt_2014_01_18_20_48-b00)
        4. Java VM: OpenJDK 64-Bit Server VM (24.45-b08 mixed mode linux-amd64 compressed oops)
        5. Problematic frame:
        6. C [libgtk-x11-2.0.so.0+0x247bc3] gtk_widget_get_tooltip_text+0x23
          #
        7. Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
          #
        8. An error report file with more information is saved as:
        9. /tmp/jvm-3555/hs_error.log
          #
        10. If you would like to submit a bug report, please include
        11. instructions on how to reproduce the bug and visit:
        12. http://icedtea.classpath.org/bugzilla
          #

        ================================

        Some information :

        Version : Apache Directory Studio 2.0.0-M3
        Distro : Mageia 4
        Kernel : 3.12.9-desktop-1.mga4 #1 SMP Sat Feb 1 18:16:06 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

        GTK related vars :

        $ env | grep -i gtk
        GTK2_RC_FILES=/etc/gtk-2.0/gtkrc:/home/nayco/.gtkrc-2.0:/home/nayco/.gtkrc-2.0-kde:/home/nayco/.kde4/share/config/gtkrc-2.0
        GTK_RC_FILES=/etc/gtk/gtkrc:/home/nayco/.gtkrc:/home/nayco/.kde4/share/config/gtkrc
        GTK_MODULES=canberra-gtk-module

        Some of my installed libs :

        lib64gtk+2.0_0-2.24.22-3.mga4
        lib64gtk+3_0-3.10.6-4.mga4
        lib64gtk+-x11-2.0_0-2.24.22-3.mga4
        lib64gtk2-theme-engines-2.20.2-2.mga4
        gtk2-theme-engines-2.20.2-2.mga4
        gtk+2.0-2.24.22-3.mga4
        gtk+3.0-3.10.6-4.mga4
        canberra-gtk-0.30-4.mga4
        lib64canberra-gtk3_0-0.30-4.mga4
        oxygen-gtk3-1.3.2-0.rc1.1.mga4
        oxygen-gtk-1.4.2-0.rc1.1.mga4
        lib64oxygen-gtk3-1.3.2-0.rc1.1.mga4
        lib64oxygen-gtk-1.4.2-0.rc1.1.mga4

        Thanks in advance for help, I can provide more info.

        Emmanuel Lecharny added a comment -

        Keep it open.

        Grégoire Paris added a comment -

        This workaround works like a charm! Thanks a lot! I guess I should leave this open though, shouldn't I ? Since it is a workaround...

        Stefan Seelmann added a comment -

        I think I found a solutions here: https://bugs.launchpad.net/ubuntu/+source/java-common/+bug/1241101

        Seems the default "Oxygen" theme causes the problem. Please try to use another theme for Studio by setting the GTK2_RC_FILES env:
        $ GTK2_RC_FILES=/usr/share/themes/Raleigh/gtk-2.0/gtkrc ./ApacheDirectoryStudio

        The Raleigh theme is installed by default but looks a bit ugly. You can install the Radiance theme which looks nicer, but not KDE like:
        $ sudo apt-get install light-themes
        $ GTK2_RC_FILES=/usr/share/themes/Radiance/gtk-2.0/gtkrc ./ApacheDirectoryStudio

        The longterm solution would be to migrate to Eclipse 4.3.

        Grégoire Paris added a comment -

        Funny, while typing "Kubuntu", I was thinking I was going to make a fool of myself with my theory about package changes... glad you could reproduce the issue. Also, if it helps, it was working fine before the upgrade to saucy.

        Stefan Seelmann added a comment -

        Kubuntu was the keyword.

        I was able to reproduce same error using Kubuntu. I installed gnome (apt-get install gnome) but under KDE it still crashes. If I start a gnome session instead of KDE it starts up, so all libraries seem to be installed. If I switch back to KDE it crashes again. I have no clue yet what the problem is.

        Grégoire Paris added a comment -

        cat /etc/lsb-release
        DISTRIB_ID=Ubuntu
        DISTRIB_RELEASE=13.10
        DISTRIB_CODENAME=saucy
        DISTRIB_DESCRIPTION="Ubuntu 13.10"

        Not sure it matters (maybe the installed packages change), but I'm using Kubuntu.

        Stefan Seelmann added a comment -

        What is the exact Ubuntu version you are using?

        Grégoire Paris made changes -
        Field Original Value New Value
        Attachment hs_err_pid24539.log [ 12615145 ]
        Grégoire Paris added a comment -

        Crash log

        Grégoire Paris created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            Grégoire Paris
          • Votes:
            3 Vote for this issue
            Watchers:
            10 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development