Uploaded image for project: 'Directory Studio'
  1. Directory Studio
  2. DIRSTUDIO-932

NPE while importing an ApacheDS 2.0 configuration from within the editor

    Details

      Description

      Import of Apache DS 2.0 configuration fails even when you import just exported, default ldif with configuration.

      http://imageshack.us/photo/my-images/594/kpej.png/

        Activity

        Hide
        pamarcelot Pierre-Arnaud Marcelot added a comment -

        Fixed at revision 1499028.

        http://svn.apache.org/r1499028

        Show
        pamarcelot Pierre-Arnaud Marcelot added a comment - Fixed at revision 1499028. http://svn.apache.org/r1499028
        Hide
        pamarcelot Pierre-Arnaud Marcelot added a comment -

        Oh, right.
        I thought you were opening it via "File" > "Open…".

        Indeed, I get the error when I try import it using the editor button.

        Show
        pamarcelot Pierre-Arnaud Marcelot added a comment - Oh, right. I thought you were opening it via "File" > "Open…". Indeed, I get the error when I try import it using the editor button.
        Hide
        klocek Łukasz Adamczyk added a comment -

        I'm using button "Import Configuration" ( http://imageshack.us/photo/my-images/19/i2g.png/ ) and with this file I have error message. Are you using the same method to import configuration ldif?

        Show
        klocek Łukasz Adamczyk added a comment - I'm using button "Import Configuration" ( http://imageshack.us/photo/my-images/19/i2g.png/ ) and with this file I have error message. Are you using the same method to import configuration ldif?
        Hide
        pamarcelot Pierre-Arnaud Marcelot added a comment -

        This file loads fine with the latest 2.0.0-M8 (2.0.0.v20130628) version (being currently mirrored) as far as I can tell.

        Show
        pamarcelot Pierre-Arnaud Marcelot added a comment - This file loads fine with the latest 2.0.0-M8 (2.0.0.v20130628) version (being currently mirrored) as far as I can tell.
        Hide
        klocek Łukasz Adamczyk added a comment -

        Ldif exported from default Apache DS 2.0.0 M14 configuration by Apache Directory Studio 2.0.0 v20130517

        Show
        klocek Łukasz Adamczyk added a comment - Ldif exported from default Apache DS 2.0.0 M14 configuration by Apache Directory Studio 2.0.0 v20130517
        Hide
        pamarcelot Pierre-Arnaud Marcelot added a comment -

        Ok, in that case, that's another issue.

        Could you share your config.ldif file please?

        Thanks!

        Show
        pamarcelot Pierre-Arnaud Marcelot added a comment - Ok, in that case, that's another issue. Could you share your config.ldif file please? Thanks!
        Hide
        klocek Łukasz Adamczyk added a comment -

        I have the same problem with Apache DS M12 (default version added to Apache Directory Studio 2.0.0-M7) and with Apache DS 13/14 with Directory Studio 2.0.0 v20130628

        Show
        klocek Łukasz Adamczyk added a comment - I have the same problem with Apache DS M12 (default version added to Apache Directory Studio 2.0.0-M7) and with Apache DS 13/14 with Directory Studio 2.0.0 v20130628
        Hide
        pamarcelot Pierre-Arnaud Marcelot added a comment - - edited

        What the version of the ApacheDS?

        If it's 2.0.0-M13 or 2.0.0-M14, note that Apache Directory Studio 2.0.0-M7 (2.0.0.v20130517) is NOT compatible with them, since they include a new attribute type for the configuration.

        Version 2.0.0-M8 has been voted to fix this issue (and more) and is currently being replicated to the Apache mirrors before being announce tomorrow.

        In the meantime, you can download it here:
        http://people.apache.org/~pamarcelot/ApacheDirectoryStudio-2.0.0.v20130628/

        Could you try and tell us if it fixes your issue (it probably will)?

        Thanks!

        Show
        pamarcelot Pierre-Arnaud Marcelot added a comment - - edited What the version of the ApacheDS? If it's 2.0.0-M13 or 2.0.0-M14, note that Apache Directory Studio 2.0.0-M7 (2.0.0.v20130517) is NOT compatible with them, since they include a new attribute type for the configuration. Version 2.0.0-M8 has been voted to fix this issue (and more) and is currently being replicated to the Apache mirrors before being announce tomorrow. In the meantime, you can download it here: http://people.apache.org/~pamarcelot/ApacheDirectoryStudio-2.0.0.v20130628/ Could you try and tell us if it fixes your issue (it probably will)? Thanks!

          People

          • Assignee:
            pamarcelot Pierre-Arnaud Marcelot
            Reporter:
            klocek Łukasz Adamczyk
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development