Uploaded image for project: 'Directory Studio'
  1. Directory Studio
  2. DIRSTUDIO-931

ERR_04269 ATTRIBUTE_TYPE for OID ads-pwdvalidator does not exist!

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.0-M7 (2.0.0.v20130517)
    • Component/s: None
    • Labels:
      None

      Description

      Due to the following error I couldn't load the server configuration.
      (I've tried to try it with the current SNAPSHOT but the latest is not starting.)

      Die Konfiguration konnte nicht geladen werden.

      • ERR_04269 ATTRIBUTE_TYPE for OID ads-pwdvalidator does not exist!
        org.apache.directory.api.ldap.model.exception.LdapNoSuchAttributeException: ERR_04269 ATTRIBUTE_TYPE for OID ads-pwdvalidator does not exist!
        at org.apache.directory.api.ldap.model.schema.registries.DefaultAttributeTypeRegistry.lookup(DefaultAttributeTypeRegistry.java:317)
        at org.apache.directory.api.ldap.model.schema.registries.DefaultAttributeTypeRegistry.lookup(DefaultAttributeTypeRegistry.java:47)
        at org.apache.directory.api.ldap.schemamanager.impl.DefaultSchemaManager.lookupAttributeTypeRegistry(DefaultSchemaManager.java:1623)
        at org.apache.directory.api.ldap.model.entry.DefaultEntry.<init>(DefaultEntry.java:311)
        at org.apache.directory.studio.apacheds.configuration.v2.jobs.LoadConfigurationRunnable.readConfiguration(LoadConfigurationRunnable.java:359)
        at org.apache.directory.studio.apacheds.configuration.v2.jobs.LoadConfigurationRunnable.getConfiguration(LoadConfigurationRunnable.java:182)
        at org.apache.directory.studio.apacheds.configuration.v2.jobs.LoadConfigurationRunnable.run(LoadConfigurationRunnable.java:127)
        at org.apache.directory.studio.common.core.jobs.StudioJob.run(StudioJob.java:83)
        at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
        Caused by: org.apache.directory.api.ldap.model.exception.LdapException: ERR_04269 ATTRIBUTE_TYPE for OID ads-pwdvalidator does not exist!
        at org.apache.directory.api.ldap.model.schema.registries.DefaultSchemaObjectRegistry.lookup(DefaultSchemaObjectRegistry.java:176)
        at org.apache.directory.api.ldap.model.schema.registries.DefaultAttributeTypeRegistry.lookup(DefaultAttributeTypeRegistry.java:313)
        ... 8 more

      ERR_04269 ATTRIBUTE_TYPE for OID ads-pwdvalidator does not exist!

        Issue Links

          Activity

          pamarcelot Pierre-Arnaud Marcelot added a comment -

          This new attribute was added in the latest version of ApacheDS.

          Apache Directory Studio 2.0.0-M8 s currently being voted and supports the latest version of ApacheDS.
          It should be out in two days or so.

          In the meantime, you can grab it here:
          http://people.apache.org/~pamarcelot/ApacheDirectoryStudio-2.0.0.v20130628/


            People

            • Assignee:
              pamarcelot Pierre-Arnaud Marcelot
              Reporter:
              me Marc Ende
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development