Directory Studio
  1. Directory Studio
  2. DIRSTUDIO-912

No connection pre-selected when DIT, Searches or Bookmarks is selected in the LDAP Brower view and the wizard is accessed via 'File' > 'Import' menu

    Details

      Description

      The second time I try to import the same LDIF I always get the error "Selected logfile already exists. Select option 'Overwrite existing logfile' if you want to overwrite the logfile." Therefore the "Finish" button is disabled. Neither selecting 'Overwrite existing logfile' nor selecting "Use custom logfile" with another name does disable this error. The only workaround is to restart Directory Studio.
      To reproduce just try to import the same LDIF twice into an embedded server with Directory Studio under Mac OS X

        Issue Links

          Activity

          Konrad Windszus created issue -
          Konrad Windszus added a comment - - edited

          Please modify the original description. The problem rather only occurs, if you select DIT in the LDAP browser, before you select import from the menu. Then the "Import Into" field is being empty and the wrong error message "Selected logfile already exists. Select option 'Overwrite existing logfile' if you want to overwrite the logfile." is shown and there is nothing you can do to proceed.. It does not happen if you select the import from the context menu from within the LDAP Browser view on DIT.

          Pierre-Arnaud Marcelot added a comment -

          I just verified and you're right!
          What a crazy issue...

          I'm debugging it now.

          Pierre-Arnaud Marcelot added a comment -

          It's also true if you select "Searches" or "Bookmarks" nodes.

          Pierre-Arnaud Marcelot made changes -
          Field Original Value New Value
          Summary Importing an LDIF twice leads to error "Selected logfile already exists. Select option 'Overwrite existing logfile' if you want to overwrite the logfile.", although overwriting log files is checked. No connection pre-selected when DIT, Searches or Bookmarks is selected in the LDAP Brower view and the wizard is accessed via 'File' > 'Import' menu
          Assignee Pierre-Arnaud Marcelot [ pamarcelot ]
          Konrad Windszus added a comment -

          Please also fix the wrong error text in case no connection was selected. It should say something like "Please first select a connection", instead of "Selected logfile already exists....".

          Pierre-Arnaud Marcelot added a comment -

          Ok, I finally debugged and have a fix for this issue.

          Looks like there were actually two problems:

          1°/ The current connection was not pre-selected when DIT, Searches or Bookmarks nodes were selected in the LDAP Browser view and the import wizard was launch from the 'File' > 'Import' menu.

          2°/ There was an issue with the error message, which was not correct. The error message should have stated that no connection was selected (direct consequence of problem #1).
          I will create a separate JIRA issue for this one.

          Pierre-Arnaud Marcelot added a comment -

          Fixed at revision 1488161.

          http://svn.apache.org/r1488161

          Pierre-Arnaud Marcelot made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Fix Version/s 2.0.0-M8 [ 12324454 ]
          Fix Version/s 2.0.0 [ 12314306 ]
          Resolution Fixed [ 1 ]
          Pierre-Arnaud Marcelot made changes -
          Link This issue is related to DIRSTUDIO-918 [ DIRSTUDIO-918 ]
          Pierre-Arnaud Marcelot made changes -
          Component/s studio-ldapbrowser [ 12311538 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Resolved Resolved
          14d 3h 33m 1 Pierre-Arnaud Marcelot 31/May/13 12:18

            People

            • Assignee:
              Pierre-Arnaud Marcelot
              Reporter:
              Konrad Windszus
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development