Directory Studio
  1. Directory Studio
  2. DIRSTUDIO-907

ERR_04269 ATTRIBUTE_TYPE for OID ads-replpingersleep does not exist!

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.0-M6 (2.0.0.v20130308)
    • Labels:
      None
    • Environment:
      Nightly Build of the Apache Studio up to 5/10/2013, Centos, ApacheDS-2.0.0-M12

      Description

      Open the connection to ApacheDS 2.0.0-M12 and right click on "open configuration", then this exception shows up.

      org.apache.directory.api.ldap.model.exception.LdapNoSuchAttributeException: ERR_04269 ATTRIBUTE_TYPE for OID ads-replpingersleep does not exist!
      at org.apache.directory.api.ldap.model.schema.registries.DefaultAttributeTypeRegistry.lookup(DefaultAttributeTypeRegistry.java:317)
      at org.apache.directory.api.ldap.model.schema.registries.DefaultAttributeTypeRegistry.lookup(DefaultAttributeTypeRegistry.java:47)
      at org.apache.directory.api.ldap.schemamanager.impl.DefaultSchemaManager.lookupAttributeTypeRegistry(DefaultSchemaManager.java:1623)
      at org.apache.directory.api.ldap.model.entry.DefaultEntry.<init>(DefaultEntry.java:311)
      at org.apache.directory.studio.apacheds.configuration.v2.jobs.LoadConfigurationRunnable.readConfiguration(LoadConfigurationRunnable.java:359)
      at org.apache.directory.studio.apacheds.configuration.v2.jobs.LoadConfigurationRunnable.getConfiguration(LoadConfigurationRunnable.java:182)
      at org.apache.directory.studio.apacheds.configuration.v2.jobs.LoadConfigurationRunnable.run(LoadConfigurationRunnable.java:127)
      at org.apache.directory.studio.common.core.jobs.StudioJob.run(StudioJob.java:83)
      at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
      Caused by: org.apache.directory.api.ldap.model.exception.LdapException: ERR_04269 ATTRIBUTE_TYPE for OID ads-replpingersleep does not exist!
      at org.apache.directory.api.ldap.model.schema.registries.DefaultSchemaObjectRegistry.lookup(DefaultSchemaObjectRegistry.java:176)
      at org.apache.directory.api.ldap.model.schema.registries.DefaultAttributeTypeRegistry.lookup(DefaultAttributeTypeRegistry.java:313)
      ... 8 more

      1. studio_907.png
        40 kB
        Olivier Drouin

        Issue Links

          Activity

          Pierre-Arnaud Marcelot added a comment -

          Fixed in trunk.

          Max Kutsevol added a comment -

          Had the same error with AD M12 and ADS M6

          Took the current nightly build of Directory Studio and the error is gone.

          Works for me.

          Thank you.

          Olivier Drouin added a comment -

          Makes me think of DIRSTUDIO-889. But the attributes were added on apacheds side it seems... Maybe we could also ignore this case.

          Emmanuel Lecharny added a comment -

          I just fixed the links. Can you give it a try ? (It may take a bit of time for the mirrors to be updated though). However, using an older version of Studio to manage ApacheDS M12 will not work either.

          Otherwise, yes, this is a bug we are awared of. We added some new AttributeType in the M12 configuration, and as Studio is built after the release of ApacheDS, you get this error when trying to open M12 configuration with Studio. This will be fixed in the next few days (I would say by next week).

          Sorry for the inconvenience...

          (Makes me think we should just ignore such errors in the next versions of Studio...)

          Olivier Drouin added a comment -

          I'd like to use an older version in the meantime but I'm getting a 404 when trying to download M5 at http://directory.apache.org/studio/download-old-versions.html

          Olivier Drouin added a comment -

          Attaching a screenshot of the issue

          Olivier Drouin added a comment -

          Hello,
          I have the same behavior. Studio is 2.0.0-M6 on Windows and DS is 2.0.0-M12 on centos 6.

          Thank you


            People

            • Assignee:
              Pierre-Arnaud Marcelot
              Reporter:
              James C. Wu
            • Votes:
              2 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development