Directory Studio
  1. Directory Studio
  2. DIRSTUDIO-899

Unable to install Studio using the update site: "Missing requirement: ApacheDS Core 2.0.0.M11"

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.0.0-M6 (2.0.0.v20130308)
    • Component/s: None
    • Labels:
      None

      Description

      This problem was reported on IRC.

      It seems like the ApacheDS Core module has a lot of imports on interceptors modules and those modules are not part of the distribution.

      Here's the log from the user:
      !MESSAGE Missing requirement: ApacheDS Core 2.0.0.M11 (org.apache.directory.server.core 2.0.0.M11) requires 'package org.apache.directory.server.core.admin [2.0.0,3.0.0)' but it could not be found

        Activity

        Pierre-Arnaud Marcelot created issue -
        Joe Gamache added a comment -

        Impacting me too - can't load the Eclipse/STS plugins due to this error....

        Pierre-Arnaud Marcelot added a comment -

        I'm not sure how this can impact the installation/load of other plugins like Eclipse STS but, in the meantime, if you still wish to use Apache Directory Studio, the standalone RCP application works fine.

        Pierre-Arnaud Marcelot added a comment -

        I've verified a few things and it looks like the dependency on the apacheds-core module is no longer in use in Studio.
        It was probably required at some point but some refactorings in ApacheDS code might have made it useless for Studio.

        Joe Gamache added a comment - - edited

        Thanks for looking at this so quickly, but

        If you take a clean install of the latest STS (and I assume Eclipse, but have not verified), and add YOUR update site. Then try to add the ApacheDS server, you get this error. So there must be a dependency in there on your end someplace!

        Ok - I was wrong!

        If you go here: http://directory.apache.org/studio/installation-in-eclipse.html

        the update site is for 1.x, but that doesn't work at all. If you change it to 2.x, then it works and just adding the browser works, but if you add both server and browser (as I suspect is most common), it gives the dependency error...

        Pierre-Arnaud Marcelot added a comment -

        Oh yeah, sure, that's the issue actually. The "apacheds-core" module as sub-dependencies that are not correctly satisfied.
        The great is that we can get rid of the "apacheds-core" dependency on Studio, so that won't be an issue anymore.

        I thought you were saying that trying to install Studio would also make installation of other plugins from other vendors fail afterwards.

        Joe Gamache added a comment -

        got it! Thanks! Looking forward to the removal of the dependency!

        Pierre-Arnaud Marcelot added a comment -

        Actually the URL on the installation page is:
        http://directory.apache.org/studio/update/2.x

        The problem is that we didn't update the screenshot, which I've just fixed.

        Thanks for pointing that.

        Pierre-Arnaud Marcelot added a comment -

        It should be fixed with commit 1464961.

        http://svn.apache.org/r1464961

        Pierre-Arnaud Marcelot made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Pierre-Arnaud Marcelot made changes -
        Fix Version/s 2.0.0 [ 12314306 ]
        oplms added a comment - - edited

        Looks like the bug is still present.
        Steps to reproduce:
        Follow guide http://directory.apache.org/studio/installation-in-eclipse.html, except instead of selecting 'LDAP Browser' select all available options. During installation, this report below is shown and installation breaks:

        Cannot complete the install because one or more required items could not be found.
        Software currently installed: Apache Directory Studio ApacheDS 2.0 Configuration 2.0.0.v20130308 (org.apache.directory.studio.apacheds.configuration.v2.feature.feature.group 2.0.0.v20130308)
        Missing requirement: ApacheDS Core 2.0.0.M11 (org.apache.directory.server.core 2.0.0.M11) requires 'package org.apache.directory.server.core.admin [2.0.0,3.0.0)' but it could not be found
        Cannot satisfy dependency:
        From: Apache Directory Studio ApacheDS 2.0 Configuration 2.0.0.v20130308 (org.apache.directory.studio.apacheds.configuration.v2.feature.feature.group 2.0.0.v20130308)
        To: org.apache.directory.server.core [2.0.0.M11]

        Using Eclipse SDK Version: 4.2.2 Build id: M20130204-1200

        oplms made changes -
        Resolution Fixed [ 1 ]
        Status Resolved [ 5 ] Reopened [ 4 ]
        Pierre-Arnaud Marcelot added a comment -

        The issue is resolved in the source repository but that's for version 2.0.0-M7, which we'll release very soon.

        Pierre-Arnaud Marcelot made changes -
        Status Reopened [ 4 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        oplms added a comment -

        Cannot complete the install because one or more required items could not be found.
        Software currently installed: Apache Directory Studio ApacheDS 2.0 Configuration 2.0.0.v20130308 (org.apache.directory.studio.apacheds.configuration.v2.feature.feature.group 2.0.0.v20130308)
        Missing requirement: ApacheDS Core 2.0.0.M11 (org.apache.directory.server.core 2.0.0.M11) requires 'package org.apache.directory.server.core.authn [2.0.0,3.0.0)' but it could not be found
        Cannot satisfy dependency:
        From: Apache Directory Studio ApacheDS 2.0 Configuration 2.0.0.v20130308 (org.apache.directory.studio.apacheds.configuration.v2.feature.feature.group 2.0.0.v20130308)
        To: org.apache.directory.server.core [2.0.0.M11]

        Problem still exists. Please, consider this issue resolved as soon, as working version will appear in the official Studio installation repository. Until then, I cannot see why this issue can be considered as resolved.

        oplms made changes -
        Resolution Fixed [ 1 ]
        Status Resolved [ 5 ] Reopened [ 4 ]
        oplms made changes -
        Comment [ Could you please put working version onto update site, then. It is impossible to perform install Studio, nor update because of this issue. ]
        Stefan Seelmann added a comment - - edited

        I can confirm the problem. I installed via eclipse marketplace but get a slightly different error message:

        Missing requirement: ApacheDS Core 2.0.0.M11 (org.apache.directory.server.core 2.0.0.M11) requires 'package org.apache.directory.server.core.admin [2.0.0,3.0.0)' but it could not be found

        When exluding the "ApacheDS 2.0 Configuration" feature the installation works.

        Pierre-Arnaud Marcelot added a comment -

        Hi Stefan,

        Indeed, I checked and fixed all dependencies. It should all be OK now (in trunk) and I will take extra-care to verify it on (test) live update site before launching the vote for 2.0.0-M7.

        Unfortunately, I wasn't available two weeks ago (I was in vacation), and I dedicated a part of last week to work on the editor for the Password Policies for the Apache DS Configuration Editor.
        I was also waiting for ApacheDS 2.0.0-M12 to be released, so I could include it in the next release of Studio.
        I'll be in vacation (again) starting on tuesday next week, I'll release Studio as soon as possible (and when it's ready) when I get back the week after.

        Regards,
        Pierre-Arnaud
        --------------------------------

        Hi oplms,

        Once again, for us, the issue is "resolved".
        If you look closely, the fix version is 2.0.0-M7, which isn't out yet and which we try to get out ASAP.

        The "resolved" state is different than the fact that the website or update site is up-to-date.
        It's linked to our work in the current trunk.
        It helps us to keep track on the work of a release and which issues are currently "resolved' for a particular version.

        In the cas of this issue, it has been fixed in trunk, so its state should be "resolved".

        That may not sound right to you, but that's the way the entire Directory Project team uses JIRA.

        Regards,
        Pierre-Arnaud

        Pierre-Arnaud Marcelot made changes -
        Status Reopened [ 4 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Pierre-Arnaud Marcelot added a comment -

        On a side note, until the next version of Apache Directory Studio and its update site are released, and if you really need to use it, the RCP application of version 2.0.0-M6 works fine and can be downloaded at:
        http://directory.apache.org/studio/downloads.html

        oplms added a comment -

        Unfortunately, standalone version of Studio is hardly usable. For example, it is not possible to change default font for editors. This option is available under 'Preferences dialog' in canonical version of Eclipse, but for some very strange reason it is absent in Studio. Next, Schema editor has no look-and-feel options at all, hence in my case it has black text on dark background.
        In fact, there is so many such kind of non-critical issues, so I can hardly use standalone version.
        And all those issues was not fixed at lest for the past year. And I really doubt it will be fixed soon, as there are more important issues (like this one) to be fixed.

        oplms added a comment -

        Could you please provide update URI for installable version, stable or not, it does not really matter.

        Emmanuel Lecharny added a comment -

        The standalone version does not load all the needed libraries to manage the L&F, that would make it really too big. This is a choice.

        Now, on my computer, and on many computers I have seen it running, the L&F is just fine, and no, it's not black text on a dark background.

        What is your OS, and what is the JVM you are using ?

        The URI are present on the directory web site : http://directory.apache.org/studio/downloads.html

        Pierre-Arnaud Marcelot added a comment -

        Hi oplms,

        Could you create JIRAs for all those (numerous?) issues (with screenshots when it comes to a UI problem)?
        This way we are aware of them and can try to fix them.

        Thanks,
        Pierre-Arnaud


          People

          • Assignee:
            Pierre-Arnaud Marcelot
            Reporter:
            Pierre-Arnaud Marcelot
          • Votes:
            1 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development