Details

      Description

      Unable to import ApacheDS core schemas.

      An error is shown for each core schema and the following exception shows up in the log:
      !ENTRY org.apache.directory.studio.schemaeditor 4 0 2013-03-20 11:26:32.094
      !MESSAGE An error occurred when loading the schema adsconfig.
      !STACK 0
      org.apache.directory.studio.schemaeditor.model.io.XMLSchemaFileImportException: The file "bundleresource://66.fwk1352618001/resources/schemas/apacheds/adsconfig.xml" can not be read correctly.
      at org.apache.directory.studio.schemaeditor.model.io.XMLSchemaFileImporter.getSchema(XMLSchemaFileImporter.java:146)
      at org.apache.directory.studio.schemaeditor.PluginUtils.loadCoreSchema(PluginUtils.java:361)
      at org.apache.directory.studio.schemaeditor.view.wizards.NewProjectWizard.performFinish(NewProjectWizard.java:181)
      at org.eclipse.jface.wizard.WizardDialog.finishPressed(WizardDialog.java:827)
      at org.eclipse.jface.wizard.WizardDialog.buttonPressed(WizardDialog.java:432)
      at org.eclipse.jface.dialogs.Dialog$2.widgetSelected(Dialog.java:624)
      at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:248)
      at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
      at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4134)
      at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1458)
      at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1481)
      at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1466)
      at org.eclipse.swt.widgets.Widget.notifyListeners(Widget.java:1271)
      at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3980)
      at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3619)
      at org.eclipse.jface.window.Window.runEventLoop(Window.java:825)
      at org.eclipse.jface.window.Window.open(Window.java:801)
      at org.apache.directory.studio.schemaeditor.controller.actions.NewProjectAction.run(NewProjectAction.java:68)
      at org.eclipse.jface.action.Action.runWithEvent(Action.java:498)
      at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:584)
      at org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:501)
      at org.eclipse.jface.action.ActionContributionItem$6.handleEvent(ActionContributionItem.java:452)
      at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
      at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4134)
      at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1458)
      at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1481)
      at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1466)
      at org.eclipse.swt.widgets.Widget.notifyListeners(Widget.java:1271)
      at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3980)
      at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3619)
      at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2701)
      at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2665)
      at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2499)
      at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:679)
      at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
      at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:668)
      at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
      at org.apache.directory.studio.Application.start(Application.java:51)
      at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:353)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:180)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:629)
      at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
      at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
      Caused by: org.dom4j.DocumentException: Error on line 19 of document : The processing instruction target matching "[xX][mM][lL]" is not allowed. Nested exception: The processing instruction target matching "[xX][mM][lL]" is not allowed.
      at org.dom4j.io.SAXReader.read(SAXReader.java:482)
      at org.dom4j.io.SAXReader.read(SAXReader.java:343)
      at org.apache.directory.studio.schemaeditor.model.io.XMLSchemaFileImporter.getSchema(XMLSchemaFileImporter.java:142)
      ... 49 more

        Activity

        Pierre-Arnaud Marcelot created issue -
        Pierre-Arnaud Marcelot made changes -
        Field Original Value New Value
        Affects Version/s 2.0.0-M6 [ 12324038 ]
        Fix Version/s 2.0.0-M7 [ 12324146 ]
        Fix Version/s 2.0.0 [ 12314306 ]
        Pierre-Arnaud Marcelot added a comment -

        Here's a screenshot of the error.

        Pierre-Arnaud Marcelot made changes -
        Attachment Screen Shot 2013-03-20 at 11.26.33.png [ 12574518 ]
        Pierre-Arnaud Marcelot added a comment -

        Fixed at revision 1458764.

        http://svn.apache.org/r1458764

        Pierre-Arnaud Marcelot made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]

          People

          • Assignee:
            Pierre-Arnaud Marcelot
            Reporter:
            Pierre-Arnaud Marcelot
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development