Directory Studio
  1. Directory Studio
  2. DIRSTUDIO-864

Error message appears: "ERR_04269 ATTRIBUTE_TYPE for OID ads-replenabled does not exist!" when trying to open configuration

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.0-M3 (2.0.0.v20120224)
    • Labels:
      None
    • Environment:

      Description

      1. Choose main menu — LDAP — Schema Browser.
      2. Open tab Attribute Types.
      The list contains attribute "ads-replEnabled".
      3. Choose a server in pane "Connections", right-click it and choose Open Configuration.

      Expected result:
      Configuration window opens.

      Actual result:
      The following exception is thrown:
      org.apache.directory.shared.ldap.model.exception.LdapNoSuchAttributeException: ERR_04269 ATTRIBUTE_TYPE for OID ads-replenabled does not exist!
      at org.apache.directory.shared.ldap.model.schema.registries.DefaultAttributeTypeRegistry.lookup(DefaultAttributeTypeRegistry.java:317)
      at org.apache.directory.shared.ldap.model.schema.registries.DefaultAttributeTypeRegistry.lookup(DefaultAttributeTypeRegistry.java:47)
      at org.apache.directory.shared.ldap.schemamanager.impl.DefaultSchemaManager.lookupAttributeTypeRegistry(DefaultSchemaManager.java:1620)
      at org.apache.directory.shared.ldap.model.entry.DefaultEntry.<init>(DefaultEntry.java:310)
      at org.apache.directory.studio.apacheds.configuration.v2.jobs.LoadConfigurationRunnable.readConfiguration(LoadConfigurationRunnable.java:358)
      at org.apache.directory.studio.apacheds.configuration.v2.jobs.LoadConfigurationRunnable.getConfiguration(LoadConfigurationRunnable.java:182)
      at org.apache.directory.studio.apacheds.configuration.v2.jobs.LoadConfigurationRunnable.run(LoadConfigurationRunnable.java:127)
      at org.apache.directory.studio.common.core.jobs.StudioJob.run(StudioJob.java:83)
      at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
      Caused by: org.apache.directory.shared.ldap.model.exception.LdapException: ERR_04269 ATTRIBUTE_TYPE for OID ads-replenabled does not exist!
      at org.apache.directory.shared.ldap.model.schema.registries.DefaultSchemaObjectRegistry.lookup(DefaultSchemaObjectRegistry.java:176)
      at org.apache.directory.shared.ldap.model.schema.registries.DefaultAttributeTypeRegistry.lookup(DefaultAttributeTypeRegistry.java:313)
      ... 8 more

      I suppose that Apache Directory Studio should search "ads-replEnabled" type, but searches "ads-replenabled" instead.

        Activity

        Pierre-Arnaud Marcelot added a comment -

        Thanks for testing and confirming it's ok.
        The vote is nearly closed and the new version should be out soon.

        cj little added a comment -

        I clearly went down the same road as James above. I thought that based on the date on my Studio version (20130308) that it was only a couple of weeks old. Apparently May is the 5th month, and March is the 3rd month. Go figure.

        I grabbed the nightly build (that it looks like Pierre fixed - thank you!) and all seems to be well. Test that before cluttering up this bug ticket, like I have.

        cj little added a comment -

        I seem to be having the same issue with fresh (<2 days old) installs of both.

        Using a default ApacheDS-2.0.0-M12 instance on Ubuntu + ApacheDirectoryStudio-macosx-x86_64-2.0.0.v20130308.dmg on OSX ML.

        Pierre-Arnaud Marcelot added a comment -

        The Jenkins job which compiles our nightly builds was down for a little less than a month.
        It explains why you got the same error, the nightly build is currently almost one month old.

        I'll fix that.

        James C. Wu added a comment -

        sorry, I got a different but similar error to this one.

        James C. Wu added a comment - - edited

        please ignore my previous comment

        James C. Wu added a comment -

        I think the problem is not yet fixed. I pulled down the nightly build and try to open the configuration of a default ApacheDS 2.0.0-M12 instance. It throws the same error.

        Andrea Gioia added a comment -

        I'm using ApacheDS M12 and Apache Directory Studio M6. The problem seem to be still there. When do you plan to release a version of the Studio that can work with the last version of ApacheDS? Moreover do you know which among the old vesions of ApacheDS works properly with the STudio 2.0.0 M6? Thanks.

        Pierre-Arnaud Marcelot added a comment -

        Fixed in the latest trunk.

        Oleksij Lupandin added a comment -

        Right, I tried ApacheDS-2.0.0-M8 and ApacheDS-2.0.0-M9.

        Pierre-Arnaud Marcelot added a comment -

        I guess you were trying to open the configuration of a recent ApacheDS version, right?
        Which one was it exactly?

        The current version of Apache Directory Studio available on the website unfortunately can't support recent versions of ApacheDS because there were some changes in the configuration schema in recent ApacheDS releases.

        The current nightly build will work with those new versions and we are currently working on getting a new release of Apache Directory Studio out.


          People

          • Assignee:
            Pierre-Arnaud Marcelot
            Reporter:
            Oleksij Lupandin
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development