Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.0.0-M3 (2.0.0.v20120224)
    • Component/s: studio-acieditor
    • Labels:
      None
    • Environment:
      Fresh installation of Apache Studio 2.x via the Eclipse update site, connected to a new instance of ApacheDS 2.0.0 created within Eclipse. Added a new partition whose context entry has administrativeRole accessControlSpecificArea.

      Description

      Creating a new accessControlSubentry fails due to inability to edit the value of the subtreeSpecification attribute. Steps to reproduce:

      Right-click on an object in the DIT, choosing New, New Entry.
      Create entry from scratch and click next.
      Add accessControlSubentry and subentry classes and click next.
      Name the object.

      At this point, behavior is inconsistent. Sometimes, an error message displays:

      An error has occurred. See error log for more details.
      java.lang.NullPointerException

      Other times, the value editor for prescriptiveACI attribute is launched. In either case, attempting to edit the value for the subtreeSpecification attribute is unsuccessful. Double clicking on the attribute or its value does nothing. Right-clicking and choosing a value editor (any, actually, included in-place and text editor) also do nothing.

        Issue Links

          Activity

          Pierre-Arnaud Marcelot added a comment -

          Thanks for the confirmation.

          Aaron J Angel added a comment -

          I believe that is the version I installed. I cannot tell for certain as the Help/About screen lists a different version: 2.0.0.v20120224. I installed and tested the snapshot and can confirm that both are now working. Thanks so much for fixing this! It has made my day.

          Pierre-Arnaud Marcelot added a comment -

          I think everything is linked and the bug on the ACI Editor made the wizard completely unstable.

          I have followed your instructions in the description and I'm now able to edit both values, Subtree Specification and ACI Specification.

          I triggered a build on our nightly build system, could you please grab this new version and test if the issue is still present?
          http://directory.apache.org/studio/nightly-builds.html

          One last question, what version were you using, 2.0.0-M3? Thanks!

          Aaron J Angel added a comment -

          My apologies; I should have reread what I wrote. That part, yes, is a duplicate.

          There is still an outstanding problem with the subtreeSpecification editor: "In either case, attempting to edit the value for the subtreeSpecification attribute is unsuccessful. Double clicking on the attribute or its value does nothing. Right-clicking and choosing a value editor (any, actually, included in-place and text editor) also do nothing." This prevents you from actually creating the subentry.

          Pierre-Arnaud Marcelot added a comment -

          Taken from your description...
          "An error has occurred. See error log for more details.
          java.lang.NullPointerException "

          Clearly there's a NPE here...

          Aaron J Angel added a comment -

          DIRSTUDIO-833 references a null-pointer while this bug describes no such error. The problem is not a null-pointer exception. The problem is the fact that the editor is not even opened.

          Additionally, DIRSTUDIO-833 describes a bug with the editor for prescriptiveACI under very specific conditions. If this is really a duplicate, please explain how.

          Pierre-Arnaud Marcelot added a comment -

          This is a duplicate of issue DIRSTUDIO-833 (NPE in ACI Item Editor when adding AttributeType permission)


            People

            • Assignee:
              Pierre-Arnaud Marcelot
              Reporter:
              Aaron J Angel
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development