Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.7.0
    • Fix Version/s: 0.8.1
    • Component/s: None
    • Labels:
      None
    • Environment:
      AMD64

      Description

      LDAP Studio cannot be started on AMD64. The following lines are in the log file.

      !SESSION 2007-04-12 18:44:11.924 -----------------------------------------------
      eclipse.buildId=unknown
      java.version=1.5.0_10
      java.vendor=Sun Microsystems Inc.
      BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
      Command-line arguments: -os linux -ws gtk -arch x86

      !ENTRY org.eclipse.osgi 4 0 2007-04-12 18:44:13.588
      !MESSAGE Application error
      !STACK 1
      java.lang.UnsatisfiedLinkError: /local/work/LDAP Studio/configuration/org.eclipse.osgi/bundles/40/1/.cp/libswt-pi-gtk-3235.so: Can't load IA 32-bit .so on a AMD 64-bit platform
      at java.lang.ClassLoader$NativeLibrary.load(Native Method)
      at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1751)
      at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1660)
      at java.lang.Runtime.loadLibrary0(Runtime.java:822)
      at java.lang.System.loadLibrary(System.java:993)
      at org.eclipse.swt.internal.Library.loadLibrary(Library.java:123)
      at org.eclipse.swt.internal.gtk.OS.<clinit>(OS.java:22)
      at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)
      at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
      at org.eclipse.swt.widgets.Display.<clinit>(Display.java:126)
      at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:433)
      at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:161)
      at org.apache.directory.ldapstudio.Application.run(Application.java:53)
      at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:78)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:92)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:68)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:400)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:177)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.eclipse.core.launcher.Main.invokeFramework(Main.java:336)
      at org.eclipse.core.launcher.Main.basicRun(Main.java:280)
      at org.eclipse.core.launcher.Main.run(Main.java:977)
      at org.eclipse.core.launcher.Main.main(Main.java:952)

      !ENTRY org.eclipse.osgi 2 0 2007-04-12 18:44:13.621
      !MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
      !SUBENTRY 1 org.eclipse.osgi 2 0 2007-04-12 18:44:13.622
      !MESSAGE Bundle update@plugins/org.eclipse.sdk_3.2.1.r321_v20060705/ was not resolved.
      !SUBENTRY 2 org.eclipse.sdk 2 0 2007-04-12 18:44:13.622
      !MESSAGE Missing required bundle org.eclipse.ui.cheatsheets_[3.2.0,4.0.0).

      !ENTRY org.eclipse.osgi 2 0 2007-04-12 18:44:13.622
      !MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
      !SUBENTRY 1 org.eclipse.osgi 2 0 2007-04-12 18:44:13.623
      !MESSAGE Bundle update@plugins/org.eclipse.sdk_3.2.1.r321_v20060705/ [38] was not resolved.
      !SUBENTRY 2 org.eclipse.sdk 2 0 2007-04-12 18:44:13.623
      !MESSAGE Missing required bundle org.eclipse.ui.cheatsheets_[3.2.0,4.0.0).

        Activity

        Pierre-Arnaud Marcelot made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Pierre-Arnaud Marcelot added a comment -

        Closed.

        Apache LDAP Studio 0.8.1 has just been released.

        Thanks Andreas for your help on this issue.

        Pierre-Arnaud Marcelot made changes -
        Status Reopened [ 4 ] Resolved [ 5 ]
        Fix Version/s 0.9.0 [ 12312287 ]
        Fix Version/s 0.8.1 [ 12312562 ]
        Resolution Fixed [ 1 ]
        Pierre-Arnaud Marcelot added a comment -
        Pierre-Arnaud Marcelot made changes -
        Resolution Fixed [ 1 ]
        Status Closed [ 6 ] Reopened [ 4 ]
        Pierre-Arnaud Marcelot added a comment -

        Reopening to edit fix-version

        Andreas Roth added a comment -

        Now this one works too.

        Pierre-Arnaud Marcelot added a comment -

        Thanks for the report and the log.

        It helped me found the problem.

        I was not using the correct config.ini in the configuration folder.

        I generated a new version and updated the download with it.

        Feel free to test it when you have a moment. There's no hurry.

        Andreas Roth added a comment -

        This one is not working. The following lines are from the log file:

        java.version=1.5.0_11
        java.vendor=Sun Microsystems Inc.
        BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
        Command-line arguments: -os linux -ws gtk -arch x86_64

        !ENTRY org.eclipse.core.runtime 2007-06-14 19:47:19.701
        !MESSAGE Product org.apache.directory.studio.product could not be found.

        !ENTRY org.eclipse.osgi 4 0 2007-06-14 19:47:19.708
        !MESSAGE Application error
        !STACK 1
        java.lang.RuntimeException: No application id has been found.
        at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:56)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:92)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:68)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:400)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:177)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at org.eclipse.core.launcher.Main.invokeFramework(Main.java:336)
        at org.eclipse.core.launcher.Main.basicRun(Main.java:280)
        at org.eclipse.core.launcher.Main.run(Main.java:977)
        at org.eclipse.core.launcher.Main.main(Main.java:952)

        !ENTRY org.eclipse.osgi 2 0 2007-06-14 19:47:19.752
        !MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
        !SUBENTRY 1 org.eclipse.osgi 2 0 2007-06-14 19:47:19.752
        !MESSAGE Bundle update@plugins/org.eclipse.sdk_3.2.1.r321_v20060705/ was not resolved.
        !SUBENTRY 2 org.eclipse.sdk 2 0 2007-06-14 19:47:19.753
        !MESSAGE Missing required bundle org.eclipse.ui.cheatsheets_[3.2.0,4.0.0).

        !ENTRY org.eclipse.osgi 2 0 2007-06-14 19:47:19.754
        !MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if i
        t exists:
        !SUBENTRY 1 org.eclipse.osgi 2 0 2007-06-14 19:47:19.754
        !MESSAGE Bundle update@plugins/org.eclipse.sdk_3.2.1.r321_v20060705/ [44] was not resolved.
        !SUBENTRY 2 org.eclipse.sdk 2 0 2007-06-14 19:47:19.754
        !MESSAGE Missing required bundle org.eclipse.ui.cheatsheets_[3.2.0,4.0.0).

        At the moment i don't have the time to track down the problem further. I will try to find the problem tomorrow.

        Pierre-Arnaud Marcelot added a comment -

        One last thing, Andreas.

        I have generated an LDAP Studio 0.8.0 version for Linux AMD64 here (the previous tar.gz was generated from the current trunk): http://people.apache.org/~pamarcelot/LDAP_Studio_0.8.0_Linux_ADM64.tar.gz

        If you could please confirm me that this one works as well.

        If it's ok, I'll release it on the website aside the others.

        Thanks.

        Pierre-Arnaud Marcelot made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Pierre-Arnaud Marcelot made changes -
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Resolved [ 5 ]
        Pierre-Arnaud Marcelot added a comment -

        Cool...

        Thanks for testing out !

        I'm resolving and closing the issue, then.

        Andreas Roth added a comment -

        It works. Nice work.

        Thank you very much.

        Pierre-Arnaud Marcelot added a comment -

        Hi again Andreas.

        I've added the new 'amd64' architecture for Linux.

        I've generated a version available here : http://people.apache.org/~pamarcelot/ApacheDirectoryStudio_Linux_AMD64.zip

        Could you please tell me if it works well on your machine ?

        Thanks a lot!

        Pierre-Arnaud Marcelot added a comment -

        Thanks Andreas.

        Sorry for the delay. I've missed your comment.

        That's a very good news.

        I'll add a new specific 'Linux 64-bit' target architecture in our build with the working files.

        Andreas Roth added a comment -

        I tried it once more and finally i got it up and running.
        I had to copy the startup.jar and the eclipse binary executable file from eclipse and put it into the ldap studio directory.

        So here are the step to get it running on AMD64:

        • download the i386 package
        • unzip it to an empty directory
        • cd into the ldapstudio directory
        • cp /usr/share/eclipse/startup.jar .
        • cp /usr/share/eclipse/eclipse ./ldapstudio
        • cp /usr/share/eclipse/plugins/org.eclipse.swt.gtk.linux.x86_64_3.2.1.v3235.jar plugins/
        • run ./ldapstudio
        Pierre-Arnaud Marcelot made changes -
        Fix Version/s 0.9.0 [ 12312287 ]
        Fix Version/s 0.8.0 [ 12312286 ]
        Pierre-Arnaud Marcelot added a comment -

        Postponed for next release, until we find a testing machine.

        Emmanuel Lecharny added a comment -

        Ole,

        as you have an AMD 64 computer, can you check why Andreas has a problem ? Pierre-Arnaud can help you live on IRC (#directory-dev) if needed.

        Thanks !

        Andreas Roth added a comment -

        I copied the following files from a eclipse installation to the plugin folder of LDAP Studio:
        plugins/org.eclipse.ui.cheatsheets_3.2.1.R321_v20060720.jar
        plugins/org.eclipse.swt.gtk.linux.x86_64_3.2.1.v3235.jar

        and removed the
        plugins/org.eclipse.swt.gtk.linux.x86_3.2.1.v3235.jar

        Afterwards i started LDAP Studio and got the following errors in the log:

        !ENTRY org.eclipse.osgi 2 0 2007-04-13 16:28:48.770
        !MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
        !SUBENTRY 1 org.eclipse.osgi 2 0 2007-04-13 16:28:48.770
        !MESSAGE Bundle update@plugins/org.eclipse.swt.gtk.linux.x86_64_3.2.1.v3235.jar [66] was not resolved.
        !SUBENTRY 2 org.eclipse.swt.gtk.linux.x86_64 2 0 2007-04-13 16:28:48.770
        !MESSAGE Platform filter did not match: (& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=x86_64))
        !SUBENTRY 2 org.eclipse.swt.gtk.linux.x86_64 2 0 2007-04-13 16:28:48.770
        !MESSAGE Missing Constraint: Fragment-Host: org.eclipse.swt; bundle-version="[3.0.0,4.0.0)"

        Pierre-Arnaud Marcelot made changes -
        Assignee Pierre-Arnaud Marcelot [ pamarcelot ]
        Pierre-Arnaud Marcelot made changes -
        Field Original Value New Value
        Fix Version/s 0.7.0 [ 12312281 ]
        Affects Version/s 0.7.0 [ 12312281 ]
        Fix Version/s 0.8.0 [ 12312286 ]
        Pierre-Arnaud Marcelot added a comment -

        Thanks for the report Andreas.

        Well, actually, it's not an AMD specific package but a 64bit specific packages that is lacking.

        Andreas, could you please copy the "org.eclipse.swt.gtk.linux.x86_64_3.2.2.v3236.jar" file situated in the plugins folder of a 64bit standard Eclipse installation into the plugins folder of LDAP Studio and start again LDAP Studio ?

        Thanks

        Emmanuel Lecharny added a comment -

        This is just because we haven't built the product on an AMD 64 computer (we don't such a computer).

        Fixing this issue should be easy, as soon as we have the org.eclipse.swt.gtk.<xxx>_3.2.1.v3235.jar for AMD.

        We are working on it, but we will need someone to test it

        Andreas Roth created issue -

          People

          • Assignee:
            Pierre-Arnaud Marcelot
            Reporter:
            Andreas Roth
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development