Directory Studio
  1. Directory Studio
  2. DIRSTUDIO-603

Error browsing/entering rfc2307 compliant host entry

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.5.1
    • Fix Version/s: 1.5.2
    • Labels:
      None
    • Environment:
      Ubuntu 9.04
      java version 1.6.0_0

      Description

      A rfc2307 entry is as follows:

      dn: cn=loopback+ipHostNumber=127.0.0.1,ou=Hosts,dc=mygfs,dc=com
      objectClass: ipHost
      objectClass: device
      objectClass: top
      cn: loopback
      ipHostNumber: 127.0.0.1

      When I browse this group I receive the following error:

      'Read Children' has encountered a problem.

      Error while reading entry

      • unexpected token: 127.0.0.1
        javax.naming.InvalidNameException: unexpected token: 127.0.0.1 [Root exception is line 1:26: unexpected token: 127.0.0.1]
        at org.apache.directory.shared.ldap.name.ComplexLdapDnParser.parseDn(ComplexLdapDnParser.java:55)
        at org.apache.directory.shared.ldap.name.LdapDnParser.parseInternal(LdapDnParser.java:97)
        at org.apache.directory.shared.ldap.name.LdapDN.<init>(LdapDN.java:205)
        at org.apache.directory.studio.ldapbrowser.core.utils.JNDIUtils.getDn(JNDIUtils.java:48)
        at org.apache.directory.studio.ldapbrowser.core.jobs.SearchRunnable.searchAndUpdateModel(SearchRunnable.java:331)
        at org.apache.directory.studio.ldapbrowser.core.jobs.InitializeChildrenRunnable.executeSearch(InitializeChildrenRunnable.java:361)
        at org.apache.directory.studio.ldapbrowser.core.jobs.InitializeChildrenRunnable.initializeChildren(InitializeChildrenRunnable.java:212)
        at org.apache.directory.studio.ldapbrowser.core.jobs.InitializeChildrenRunnable.run(InitializeChildrenRunnable.java:171)
        at org.apache.directory.studio.connection.core.jobs.StudioConnectionJob.run(StudioConnectionJob.java:114)
        at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
        Caused by: line 1:26: unexpected token: 127.0.0.1
        at org.apache.directory.shared.ldap.name.AntlrDnParser.attributeValue(AntlrDnParser.java:550)
        at org.apache.directory.shared.ldap.name.AntlrDnParser.attributeTypeAndValue(AntlrDnParser.java:405)
        at org.apache.directory.shared.ldap.name.AntlrDnParser.relativeDistinguishedName(AntlrDnParser.java:252)
        at org.apache.directory.shared.ldap.name.AntlrDnParser.relativeDistinguishedNames(AntlrDnParser.java:307)
        at org.apache.directory.shared.ldap.name.ComplexLdapDnParser.parseDn(ComplexLdapDnParser.java:51)
        ... 9 more

      unexpected token: 127.0.0.1

      When I use the "new entry from scratch" wizard I receive an "invalid RDN" during data entry. First I select the three object classes from above. I then add the cn= entry. I then start entering the ipHostNumber and if the host number ends in ".[0-9]" the preview says "RDN is invalid". If I end the ipHostNumber with a "." or ".[a-zA-Z]" the RDN is accepted and the entry created. The entries that are created in this manner are viewable in the browser.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open In Progress In Progress
        1d 23h 9m 1 Stefan Seelmann 06/Dec/09 12:54
        In Progress In Progress Resolved Resolved
        4h 9m 1 Stefan Seelmann 06/Dec/09 17:03
        Resolved Resolved Closed Closed
        136d 15h 1m 1 Pierre-Arnaud Marcelot 22/Apr/10 09:05
        Pierre-Arnaud Marcelot made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Pierre-Arnaud Marcelot added a comment -

        Version 1.5.2 has been released.
        Let's close this issue.

        Pierre-Arnaud Marcelot made changes -
        Component/s studio-ldapbrowser [ 12311538 ]
        Stefan Seelmann made changes -
        Status In Progress [ 3 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Stefan Seelmann added a comment -

        This is a problem with the new DN parser, it detects a "Numeric OID" token which is not included as valid value.

        Stefan Seelmann made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        Stefan Seelmann made changes -
        Assignee Stefan Seelmann [ seelmann ]
        Pierre-Arnaud Marcelot made changes -
        Field Original Value New Value
        Fix Version/s 1.5.2 [ 12314436 ]
        Jonathan Craig created issue -

          People

          • Assignee:
            Stefan Seelmann
            Reporter:
            Jonathan Craig
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development