Directory Studio
  1. Directory Studio
  2. DIRSTUDIO-574

Add 'Cancel' button to "Select copy strategy" (was Abort of copy/paste not possible)

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.5.0
    • Component/s: studio-ldapbrowser
    • Labels:
      None
    • Environment:
      All

      Description

      It's not possible to cancel to process once you selected once you selected 'Paste Entry'. It produces an error.

      Reproduce:

      • Open the LDAP Browser view
      • Select an entry (Copy Entry / DN)
      • Try to paste it to the parent of the selected entry

      You get the "Select copy strategy" box, which contains only an "OK" button. Even when I try to close the box I get an error box, saying that the entry already exists (LDAP: error code 68)

        Activity

        Stefan Seelmann added a comment -

        The first option "Stop copy process" does what you want. But I must admit that isn't very intuitive. At least when closing the box "stop" should be the default behaviour and no error should occur.

        Felix Knecht added a comment -

        Thanks Stefan for explanation.

        It's indeed not that intuitive, at least it wasn't for me
        Therefore changing the issue to type "Improvement"

        Felix Knecht added a comment -

        But even using "Stop copy process" I get following Modification Logs:

        #!RESULT ERROR
        #!CONNECTION ldap://ldap.felixknecht.ch:389
        #!DATE 2009-10-23T21:49:39.683
        #!ERROR [LDAP: error code 68 - Entry Already Exists]
        dn: cn=foo.bar,ou=Hosts,dc=foo,dc=ch
        changetype: add
        ipHostNumber: 192.168.xxx.xxx
        objectClass: ipHost
        objectClass: top
        objectClass: device
        cn: foo.bar

        and I see splashing the error box, but disappearing immediately again ...

        Felix Knecht added a comment -

        Patch to add Cancel button and fix closing window. This doesn't fix the problem of getting an error as log entry.

        I don't commit the patch because releasing studio 1.5 is in progress.

        Felix Knecht added a comment -

        Patch applied

        Stefan Seelmann added a comment -

        Now EntryExistsCopyStrategy.BREAK is also used when selecting another strategy and pressing the OK button, because the close() method is called whenever the dialogs is closed.

        I'd suggest to remove the close() method and set EntryExistsCopyStrategy.BREAK as default in the constructor. In that case the cancelPressed() method is also not necessary.

        Felix Knecht added a comment -

        Autsch, I didn't tested enough , thanks for pointing.

        I hope it's working now like expected.

        Stefan Seelmann added a comment -

        Just perfect

        Pierre-Arnaud Marcelot added a comment -

        Apache Directory Studio version 1.5.0 has been released.


          People

          • Assignee:
            Felix Knecht
            Reporter:
            Felix Knecht
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development