Directory Studio
  1. Directory Studio
  2. DIRSTUDIO-493

Aliased attributes show only one attribute name in the RDN selection list instead of the full aliases list

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.4.0
    • Fix Version/s: 1.5.0
    • Component/s: studio-ldapbrowser
    • Labels:
      None
    • Environment:
      WXP SP2 JDk 1.5

      Description

      Hi

      When defining a attribute of a RDN, the selection list does not show up all attribute's name or alias as for example for the OrganizationalUnit object, only the 'ou' name is displayed while there should be also the 'organizationalUnitName'.
      Same apply for commonName/cn, organizationName/o, countryName/c, etc...

      Rgds

        Activity

        Pierre-Arnaud Marcelot added a comment -

        Apache Directory Studio version 1.5.0 has been released.

        Stefan Seelmann added a comment -

        Fixed in trunk.

        Stefan Seelmann added a comment -

        Thanks for the detailed information.

        I must apologize, I used the current development version of Studio for my test, and there is already a change that shows the alias name. I have to do some more tests, but this bug should be fixed in the next version.

        Francis ANDRE added a comment -

        Hi

        I am using ApacheDirectoryStudio 1.4.0.v20090407 with the OpenDS LDAP. The schema defines all aliases as follow

        dn: cn=schema
        objectClass: top
        objectClass: ldapSubentry
        objectClass: subschema
        ...
        ...
        attributeTypes: ( 2.5.4.3 NAME ( 'cn' 'commonName' ) SUP name
        X-ORIGIN 'RFC 4519' )
        attributeTypes: ( 2.5.4.4 NAME ( 'sn' 'surname' ) SUP name
        X-ORIGIN 'RFC 4519' )
        attributeTypes: ( 2.5.4.5 NAME 'serialNumber' EQUALITY caseIgnoreMatch
        SUBSTR caseIgnoreSubstringsMatch SYNTAX 1.3.6.1.4.1.1466.115.121.1.44

        {64}

        X-ORIGIN 'RFC 4519' )
        attributeTypes: ( 2.5.4.6 NAME ( 'c' 'countryName' ) SUP name SINGLE-VALUE
        X-ORIGIN 'RFC 4519' )
        attributeTypes: ( 2.5.4.7 NAME ( 'l' 'localityName' ) SUP name
        X-ORIGIN 'RFC 4519' )
        attributeTypes: ( 2.5.4.8 NAME ( 'st' 'stateOrProvinceName' ) SUP name
        X-ORIGIN 'RFC 4519' )

        Francis ANDRE added a comment -

        Only cn is displayed while commonName should be also there

        Francis ANDRE added a comment -

        Only the c attribute alias is displayed while the countryName should be also there

        Stefan Seelmann added a comment -

        I can't reproduce.

        I tested the following use cases:

        • Create a new entry (intetOrgPerson) using the New Entry wizard.
        • Rename an entry
        • Add an attribute

        In all cases the drop-down list as well as the content-assist list contains the aliases (gn/givenname, cn/commonName, etc.)

        In which case are the aliased attribute names missing?
        Which version of Studio are you using?
        Which LDAP server are you using?
        Could you please check the schema of your LDAP schema, if it defines the aliased attribute names?


          People

          • Assignee:
            Stefan Seelmann
            Reporter:
            Francis ANDRE
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development