Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.4.0
    • Fix Version/s: 1.5.0
    • Component/s: studio-ldapbrowser
    • Labels:
      None

      Description

      Studio becomes very slow when importing an LDIF with thousands of entries.

        Activity

        Stefan Seelmann created issue -
        Stefan Seelmann added a comment -

        The cause were too many UI updates, there was one UI update for each imported entry.

        Fixed in trunk:
        http://svn.apache.org/viewvc?rev=774686&view=rev

        We have a central class that is used to fire updates of the LDAP browser model. I added a counter and some debug code: if there are more then 5 events fired in one second then a warning and a stack trace is printed to the logfile. This way we will find other parts the cause massive UI updates.

        Stefan Seelmann made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Pierre-Arnaud Marcelot added a comment -

        Apache Directory studio version 1.5.0 has been released.

        Pierre-Arnaud Marcelot made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        7d 11h 24m 1 Stefan Seelmann 14/May/09 10:04
        Resolved Resolved Closed Closed
        189d 6h 34m 1 Pierre-Arnaud Marcelot 19/Nov/09 15:38

          People

          • Assignee:
            Stefan Seelmann
            Reporter:
            Stefan Seelmann
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development