Directory Studio
  1. Directory Studio
  2. DIRSTUDIO-488

New context entry creation is not shown just after connection

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.4.0
    • Fix Version/s: 1.5.0
    • Component/s: studio-ldapbrowser
    • Labels:
      None

      Description

      When connecting on a server, if one right click on the DIT, the menu offers to create a new entry, not a context entry. If one click on, say, rootDSE just after the connection, then right-click on the DIT, then the menu offers to create a context-entry.

      It seems that the state is not correctly updated after the connection, some initial action being necessary to be able to have the correct menu.

      A very minor problem though ...

        Activity

        Pierre-Arnaud Marcelot added a comment -

        Apache Directory Studio version 1.5.0 has been released.

        Stefan Seelmann added a comment -

        Fixed in trunk:
        http://svn.apache.org/viewvc?rev=822918&view=rev

        Moved all "new" actions into a "New >" sub-menu. There are now two separate actions, one for "new entry" and one for "new context entry".

        Pierre-Arnaud Marcelot added a comment -

        I think that's a very good idea Stefan.

        I'd vote for your first option.

        New >
        New Entry
        New Context Entry
        New Search
        New Bookmark
        New Batch Operation

        Stefan Seelmann added a comment -

        I think this is intented behaviour: The "New Context Entry" is only shown if the RootDSE is selected. If another entry is selected then the "New Entry" menu item is visible. The cause is to avoid that the context menu becomes overfilled (maybe it alrady is). So the item toggles dependent on the selected entry.

        Maybe an option would be to reorganize the context menu and put all "New" actions into a "New >" sub-menu?

        New >
        New Entry
        New Context Entry
        New Search
        New Bookmark
        New Batch Operation

        We could keep the "New Entry" menu item at top level, as is may be used more frequently:

        New >
        New Context Entry
        New Search
        New Bookmark
        New Batch Operation
        New Entry

        Pierre-Arnaud Marcelot added a comment -

        It seems to be working fine for me...

        I'm getting the "New Context Entry" menu item when I right-click on the "Root DSE" and "DIT" nodes.

        I tried with an old connection but also with a freshly created connection.


          People

          • Assignee:
            Stefan Seelmann
            Reporter:
            Emmanuel Lecharny
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development