Directory Studio
  1. Directory Studio
  2. DIRSTUDIO-440

Multiple user permissions precedence issue

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.3.0
    • Fix Version/s: 1.4.0
    • Component/s: studio-acieditor
    • Labels:
      None
    • Environment:
      Windows XP SP3

      Description

      When adding the appended prescriptiveACI, the precedence values for the specific User Permissions get reset to the precedence for the prescriptiveACI upon exiting the ACI Item editor.

      ======================================================================

      {
      identificationTag "test",
      precedence 14,
      authenticationLevel simple,
      itemOrUserFirst userFirst:
      {
      userClasses

      { allUsers }

      ,
      userPermissions
      {
      {
      precedence 1,
      protectedItems

      { entry, allUserAttributeTypesAndValues }

      ,
      grantsAndDenials

      { grantReturnDN, grantBrowse, grantRead }

      }
      ,
      {
      precedence 2,
      protectedItems
      {
      attributeType

      { userPassword }


      }
      ,
      grantsAndDenials

      { denyReturnDN, denyRead, denyBrowse }

      }
      }
      }
      }

        Activity

        Tycho Eggen created issue -
        Tycho Eggen added a comment -

        I might not have been entirely clear, but the precedence set under userPermissions result in being set to 14.

        Stefan Seelmann made changes -
        Field Original Value New Value
        Assignee Stefan Seelmann [ seelmann ]
        Component/s studio-acieditor [ 12311564 ]
        Affects Version/s 1.3.0 [ 12313309 ]
        Fix Version/s 1.4.0 [ 12313402 ]
        Stefan Seelmann added a comment -

        Fixed in trunk:
        http://svn.apache.org/viewvc?rev=730519&view=rev
        http://svn.apache.org/viewvc?rev=730520&view=rev

        The problem is fixed, it will be available with the next Studio version 1.4.0.

        Stefan Seelmann made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Pierre-Arnaud Marcelot added a comment -

        Apache Directory Studio version 1.4.0 has been released.

        Pierre-Arnaud Marcelot made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        1d 32m 1 Stefan Seelmann 01/Jan/09 09:55
        Resolved Resolved Closed Closed
        322d 5h 52m 1 Pierre-Arnaud Marcelot 19/Nov/09 15:47

          People

          • Assignee:
            Stefan Seelmann
            Reporter:
            Tycho Eggen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development