Directory Studio
  1. Directory Studio
  2. DIRSTUDIO-432

Better error message for invalid LDIF records on import

    Details

      Description

      If there is something wrong with an LDIF, Studio only says Record is invalid.

      Instead it should give the line of the error and a description of the problem.

      e.g. ':' missing in line 5 of the record

      1. screenshot-1.jpg
        33 kB
        Jürgen Weber

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        1118d 19h 52m 1 Pierre-Arnaud Marcelot 21/Dec/11 13:23
        Resolved Resolved Closed Closed
        36d 3h 54m 1 Pierre-Arnaud Marcelot 26/Jan/12 17:18
        Pierre-Arnaud Marcelot made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Pierre-Arnaud Marcelot added a comment -

        Version 2.0.0 M1 has been released.

        Closing the issue.

        Pierre-Arnaud Marcelot made changes -
        Fix Version/s 2.0.0-M1 [ 12319458 ]
        Pierre-Arnaud Marcelot made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Assignee Pierre-Arnaud Marcelot [ pamarcelot ]
        Resolution Fixed [ 1 ]
        Pierre-Arnaud Marcelot added a comment -

        Fixed at revision 1221714.

        http://svn.apache.org/viewvc?rev=1221714&view=rev

        We added the cause of the invalid record in the error message.

        Pierre-Arnaud Marcelot made changes -
        Fix Version/s 2.0.0 [ 12314306 ]
        Jürgen Weber made changes -
        Field Original Value New Value
        Attachment screenshot-1.jpg [ 12394858 ]
        Jürgen Weber created issue -

          People

          • Assignee:
            Pierre-Arnaud Marcelot
            Reporter:
            Jürgen Weber
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development