Directory Studio
  1. Directory Studio
  2. DIRSTUDIO-266

OpenLDAP schema files parser fails when DESC contains an empty string ''

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.1
    • Fix Version/s: 1.2.0
    • Component/s: studio-schemaeditor
    • Labels:
      None

      Description

      I've created this issue from the report on the ML of "Torgeir Veimo, in a thread called "directory studio & schema files", where he explains:
      "Directory Studio seems to be very picky about the schema files when importing a schema, eg. it doesn't seem to like a DESC field with an
      empty string, ''."

        Activity

        Pierre-Arnaud Marcelot created issue -
        Pierre-Arnaud Marcelot added a comment -

        This issue is related to the parser in the Apache Directory Shared LDAP project (used both in the Server and Studio project).
        Emmanuel has fixed this DESC problem in the latest trunk.
        We'll need to get a new release of the Apache Directory Shared LDAP project to fix this issue.

        Pierre-Arnaud Marcelot made changes -
        Field Original Value New Value
        Fix Version/s 1.1.0 [ 12312701 ]
        Assignee Pierre-Arnaud Marcelot [ pamarcelot ]
        Pierre-Arnaud Marcelot added a comment -

        I tested but the issue is still present with the just released Shared 0.9.8.

        Postponed for a next version.

        Pierre-Arnaud Marcelot made changes -
        Fix Version/s 1.2.0 [ 12312851 ]
        Fix Version/s 1.1.0 [ 12312701 ]
        Stefan Seelmann added a comment -

        This should be fixed now with DIRSHARED-8.

        Pierre-Arnaud Marcelot added a comment -

        You're right, Stefan!

        It's fixed now.

        Thanks

        Pierre-Arnaud Marcelot made changes -
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        143d 15h 11m 1 Pierre-Arnaud Marcelot 13/Jun/08 08:04

          People

          • Assignee:
            Pierre-Arnaud Marcelot
            Reporter:
            Pierre-Arnaud Marcelot
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development